# CVE-2018-3777: restforce vulnerable to Improper Input Validation

> Attackers can inject arbitrary parameters into Salesforce API requests due to insufficient URI encoding in the restforce Ruby gem.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Aug 2018
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-534w-937m-v7x3

## What is CVE-2018-3777?

CVE-2018-3777 is a critical vulnerability in https://github.com/restforce restforce ruby gem, published on 3 Aug 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Insufficient URI encoding in restforce before 3.0.0 allows attacker to inject arbitrary parameters into Salesforce API requests.

Weakness: CWE-172 (Improper Encoding or Decoding of Data), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2018-3777?

2 open source packages ship an affected version, including restforce. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `restforce` | RubyGems | All versions | 3.0.0 |
| `restforce` | RubyGems | All versions | 3.0.0 |

Products: Restforce Restforce.

## How do I fix CVE-2018-3777?

Upgrade restforce to 3.0.0 or later.

## Is CVE-2018-3777 being exploited?

There is no known exploitation of CVE-2018-3777 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-3777 and fix it if it is affected.

What it is: CVE-2018-3777 is a critical vulnerability in https://github.com/restforce restforce ruby gem, published on 3 Aug 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-3777 in the wild and no public exploit code.

Affected packages and fixed versions:
- restforce (RubyGems): affected all versions; fixed in 3.0.0
- restforce (RubyGems): affected all versions; fixed in 3.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-3777/ (Markdown: https://insights.sbomify.com/CVE-2018-3777/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-3777
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-3777
- OSV: https://osv.dev/vulnerability/CVE-2018-3777

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-3777/
Summaries are generated and may contain mistakes; the official description above is the record.
