# CVE-2018-3778: Improper Authorization in aedes

> An attacker can publish Last Will and Testament messages to unauthorized channels in the aedes MQTT broker library.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Aug 2018
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-4cmx-hrq9-c23p

## What is CVE-2018-3778?

CVE-2018-3778 is a medium-severity missing authorization vulnerability in HackerOne aedes, published on 8 Aug 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Improper authorization in aedes version <0.35.0 will publish a LWT in a channel when a client is not authorized.

Weakness: CWE-863 (Incorrect Authorization), CWE-285 (Improper Authorization)

## Which versions are affected by CVE-2018-3778?

2 open source packages ship an affected version, including aedes. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `aedes` | npm | All versions | 0.35.1 |
| `aedes` | npm | All versions | 0.35.1 |

Products: Aedes Project Aedes.

## How do I fix CVE-2018-3778?

Upgrade aedes to 0.35.1 or later.

## Is CVE-2018-3778 being exploited?

There is no known exploitation of CVE-2018-3778 in the wild and no public exploit code.

## Other vulnerabilities in HackerOne aedes

- [CVE-2020-13410](https://insights.sbomify.com/CVE-2020-13410/): Improper exception handling in Aedes (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-3778 and fix it if it is affected.

What it is: CVE-2018-3778 is a medium-severity missing authorization vulnerability in HackerOne aedes, published on 8 Aug 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-3778 in the wild and no public exploit code.

Affected packages and fixed versions:
- aedes (npm): affected all versions; fixed in 0.35.1
- aedes (npm): affected all versions; fixed in 0.35.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-3778/ (Markdown: https://insights.sbomify.com/CVE-2018-3778/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-3778
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-3778
- OSV: https://osv.dev/vulnerability/CVE-2018-3778

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-3778/
Summaries are generated and may contain mistakes; the official description above is the record.
