# CVE-2018-3783: Privilege Escalation due to Blind NoSQL Injection in flintcms

> Blind MongoDB injection in password reset allows attackers to take over accounts and escalate privileges in Flint CMS.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Aug 2018
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-jhq3-57xh-6643

## What is CVE-2018-3783?

CVE-2018-3783 is a critical SQL injection vulnerability in https://github.com/JasonEtco flintcms, published on 17 Aug 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A privilege escalation detected in flintcms versions <= 1.1.9 allows account takeover due to blind MongoDB injection in password reset.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2018-3783?

2 open source packages ship an affected version, including flintcms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `flintcms` | npm | All versions | 1.1.10 |
| `flintcms` | npm | All versions | 1.1.10 |

Products: Flintcms Flintcms.

## How do I fix CVE-2018-3783?

Upgrade flintcms to 1.1.10 or later.

## Is CVE-2018-3783 being exploited?

There is no known exploitation of CVE-2018-3783 in the wild and no public exploit code.

Public exploit code:

- Blind noSQL injection case study lab based on CVE-2018-3783 (github_poc): https://github.com/nisaruj/nosqli-flintcms

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-3783 and fix it if it is affected.

What it is: CVE-2018-3783 is a critical SQL injection vulnerability in https://github.com/JasonEtco flintcms, published on 17 Aug 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-3783 in the wild and no public exploit code.

Affected packages and fixed versions:
- flintcms (npm): affected all versions; fixed in 1.1.10
- flintcms (npm): affected all versions; fixed in 1.1.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-3783/ (Markdown: https://insights.sbomify.com/CVE-2018-3783/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-3783
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-3783
- OSV: https://osv.dev/vulnerability/CVE-2018-3783

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-3783/
Summaries are generated and may contain mistakes; the official description above is the record.
