{"answers":{"affected":"2 open source packages ship an affected version, including egg-scripts. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-3786 in the wild and no public exploit code.","fix":"Upgrade egg-scripts to 2.8.1 or later.","what":"CVE-2018-3786 is a critical command injection vulnerability in egg-scripts, published on 24 Aug 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-3786 and fix it if it is affected.\n\nWhat it is: CVE-2018-3786 is a critical command injection vulnerability in egg-scripts, published on 24 Aug 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-3786 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- egg-scripts (npm): affected all versions; fixed in 2.8.1\n- egg-scripts (npm): affected all versions; fixed in 2.8.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-3786/ (Markdown: https://insights.sbomify.com/CVE-2018-3786/index.md)","id":"CVE-2018-3786","markdown":"https://insights.sbomify.com/CVE-2018-3786/index.md","name":"CVE-2018-3786","record":{"aliases":["GHSA-c9j3-wqph-5xx9"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Egg.js scripts library","requires_auth":"none","summary":"Attackers can execute arbitrary shell commands via malicious arguments in the egg-scripts library, requiring an upgrade to mitigate.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"hackerone","cpe":[{"product":"egg-scripts","vendor":"eggjs"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-78","name":"Improper Neutralization of Special Elements used in an OS Command"},{"id":"CWE-77","name":"Improper Neutralization of Special Elements used in a Command"}],"description":"A command injection vulnerability in egg-scripts \u003cv2.8.1 allows arbitrary shell command execution through a maliciously crafted command line argument.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":"2020-05-19","github_poc":1,"max_poc_stars":0,"metasploit":0,"nuclei":0,"refs":[{"date":"2020-05-19T12:21:16Z","kind":"github_poc","ref":"https://github.com/erik-krogh/egg-scripts-CVE-2018-3786","stars":0,"title":"A fork of an old version of egg-scripts"}],"tier":"poc_unverified"},"has_fix":true,"headline":"Command Injection in egg-scripts","id":"CVE-2018-3786","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"command_injection","year":"2018"},"n_packages":2,"n_references":3,"next":{"headline":"simplehttpserver allows directory traversal and file listing","id":"CVE-2018-3787"},"packages":[{"ecosystem":"npm","fixed":["2.8.1"],"introduced":["0"],"last_affected":[],"package":"egg-scripts","purl":null,"source":"GHSA-c9j3-wqph-5xx9"},{"ecosystem":"npm","fixed":["2.8.1"],"introduced":["0"],"last_affected":[],"package":"egg-scripts","purl":"pkg:npm/egg-scripts","source":"GHSA-c9j3-wqph-5xx9"}],"prev":{"headline":"Command Injection in git-dummy-commit","id":"CVE-2018-3785"},"products":["egg-scripts"],"published":"2018-08-24","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["Egg"]},"summary":"Attackers can execute arbitrary shell commands via malicious arguments in the egg-scripts library, requiring an upgrade to mitigate.","url":"https://insights.sbomify.com/CVE-2018-3786/"}