# CVE-2018-3787: simplehttpserver allows directory traversal and file listing

> An attacker can exploit a path traversal flaw in simplehttpserver to list any file on the server, leading to information disclosure.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Aug 2018
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-gpvj-q7fp-jcch

## What is CVE-2018-3787?

CVE-2018-3787 is a high-severity path traversal vulnerability in HackerOne simplehttpserver, published on 31 Aug 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Path traversal in simplehttpserver <v0.2.1 allows listing any file on the server.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2018-3787?

2 open source packages ship an affected version, including simplehttpserver. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `simplehttpserver` | npm | All versions | 0.2.1 |
| `simplehttpserver` | npm | All versions | 0.2.1 |

Products: Simplehttpserver Project Simplehttpserver.

## How do I fix CVE-2018-3787?

Upgrade simplehttpserver to 0.2.1 or later.

## Is CVE-2018-3787 being exploited?

There is no known exploitation of CVE-2018-3787 in the wild and no public exploit code.

## Other vulnerabilities in HackerOne simplehttpserver

- [CVE-2018-3716](https://insights.sbomify.com/CVE-2018-3716/): Stored Cross-Site Scripting in simplehttpserver (medium 5.4)
- [CVE-2018-16478](https://insights.sbomify.com/CVE-2018-16478/): Path Traversal in simplehttpserver (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-3787 and fix it if it is affected.

What it is: CVE-2018-3787 is a high-severity path traversal vulnerability in HackerOne simplehttpserver, published on 31 Aug 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-3787 in the wild and no public exploit code.

Affected packages and fixed versions:
- simplehttpserver (npm): affected all versions; fixed in 0.2.1
- simplehttpserver (npm): affected all versions; fixed in 0.2.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-3787/ (Markdown: https://insights.sbomify.com/CVE-2018-3787/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-3787
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-3787
- OSV: https://osv.dev/vulnerability/CVE-2018-3787

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-3787/
Summaries are generated and may contain mistakes; the official description above is the record.
