# CVE-2018-3824: Elasticsearch subject to cross site scripting

> Attackers can inject malicious scripts into Machine Learning job results, allowing them to steal sensitive information or perform destructive actions on behalf of other users.

- **Severity:** Medium 6.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 19 Sep 2018
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-mjpc-qx7h-r8c9

## What is CVE-2018-3824?

CVE-2018-3824 is a medium-severity cross-site scripting vulnerability in Elasticsearch X-Pack Machine Learning, published on 19 Sep 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

X-Pack Machine Learning versions before 6.2.4 and 5.6.9 had a cross-site scripting (XSS) vulnerability. If an attacker is able to inject data into an index that has a ML job running against it, then when another user views the results of the ML job it could allow the attacker to obtain sensitive information from or perform destructive actions on behalf of that other ML user.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2018-3824?

4 open source packages ship an affected version, including org.elasticsearch:elasticsearch. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.elasticsearch:elasticsearch` | Maven | All versions | 5.6.9 |
| `org.elasticsearch:elasticsearch` | Maven | All versions | 5.6.9 |
| `org.elasticsearch:elasticsearch` | Maven | From 6.0.0 | 6.2.4 |
| `org.elasticsearch:elasticsearch` | Maven | From 6.0.0 | 6.2.4 |

Products: Elastic Elasticsearch X-Pack, Elastic Kibana X-Pack, Elastic Logstash X-Pack.

## How do I fix CVE-2018-3824?

Upgrade org.elasticsearch:elasticsearch to a fixed version for your release line: 5.6.9 or 6.2.4.

## Is CVE-2018-3824 being exploited?

There is no known exploitation of CVE-2018-3824 in the wild and no public exploit code.

## Other vulnerabilities in Elasticsearch X-Pack Machine Learning

- [CVE-2018-3823](https://insights.sbomify.com/CVE-2018-3823/): Cross-site scripting in Elasticsearch X-Pack Machine Learning (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-3824 and fix it if it is affected.

What it is: CVE-2018-3824 is a medium-severity cross-site scripting vulnerability in Elasticsearch X-Pack Machine Learning, published on 19 Sep 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2018-3824 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.elasticsearch:elasticsearch (Maven): affected all versions; fixed in 5.6.9
- org.elasticsearch:elasticsearch (Maven): affected all versions; fixed in 5.6.9
- org.elasticsearch:elasticsearch (Maven): affected from 6.0.0; fixed in 6.2.4
- org.elasticsearch:elasticsearch (Maven): affected from 6.0.0; fixed in 6.2.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-3824/ (Markdown: https://insights.sbomify.com/CVE-2018-3824/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-3824
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-3824
- OSV: https://osv.dev/vulnerability/CVE-2018-3824

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-3824/
Summaries are generated and may contain mistakes; the official description above is the record.
