CVE-2018-3831 Exposure of Sensitive Information to an Unauthorized Actor in Elasticsearch

High 8.8 Published Updated

Authenticated users can view sensitive configuration secrets like passwords and tokens via the cluster settings API in Elasticsearch.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2018-3831?

CVE-2018-3831 is a high-severity vulnerability in Elastic Elasticsearch, published on 19 Sep 2018. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Elasticsearch Alerting and Monitoring in versions before 6.4.1 or 5.6.12 have an information disclosure issue when secrets are configured via the API. The Elasticsearch _cluster/settings API, when queried, could leak sensitive configuration information such as passwords, tokens, or usernames. This could allow an authenticated Elasticsearch user to improperly view these details.

Weakness: CWE-200

Which versions are affected by CVE-2018-3831?

4 open source packages ship an affected version, including org.elasticsearch:elasticsearch. It affects 1 product.

PackageAffectedFixed in
org.elasticsearch:elasticsearch MavenFrom 5.6.05.6.12
org.elasticsearch:elasticsearch MavenFrom 5.6.05.6.12
org.elasticsearch:elasticsearch MavenFrom 6.0.06.4.1
org.elasticsearch:elasticsearch MavenFrom 6.0.06.4.1

Products include Elastic Elasticsearch.

How do I fix CVE-2018-3831?

Upgrade org.elasticsearch:elasticsearch to a fixed version for your release line: 5.6.12 or 6.4.1.

Is CVE-2018-3831 being exploited?

There is no known exploitation of CVE-2018-3831 in the wild and no public exploit code.

All Elastic Elasticsearch vulnerabilities

Sources

Also known as GHSA-r9fv-qpm9-rj4g.

Is CVE-2018-3831 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free