# CVE-2018-3831: Exposure of Sensitive Information to an Unauthorized Actor in Elasticsearch

> Authenticated users can view sensitive configuration secrets like passwords and tokens via the cluster settings API in Elasticsearch.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Sep 2018
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-r9fv-qpm9-rj4g

## What is CVE-2018-3831?

CVE-2018-3831 is a high-severity vulnerability in Elastic Elasticsearch, published on 19 Sep 2018. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Elasticsearch Alerting and Monitoring in versions before 6.4.1 or 5.6.12 have an information disclosure issue when secrets are configured via the API. The Elasticsearch _cluster/settings API, when queried, could leak sensitive configuration information such as passwords, tokens, or usernames. This could allow an authenticated Elasticsearch user to improperly view these details.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2018-3831?

4 open source packages ship an affected version, including org.elasticsearch:elasticsearch. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.elasticsearch:elasticsearch` | Maven | From 5.6.0 | 5.6.12 |
| `org.elasticsearch:elasticsearch` | Maven | From 5.6.0 | 5.6.12 |
| `org.elasticsearch:elasticsearch` | Maven | From 6.0.0 | 6.4.1 |
| `org.elasticsearch:elasticsearch` | Maven | From 6.0.0 | 6.4.1 |

Products: Elastic Elasticsearch.

## How do I fix CVE-2018-3831?

Upgrade org.elasticsearch:elasticsearch to a fixed version for your release line: 5.6.12 or 6.4.1.

## Is CVE-2018-3831 being exploited?

There is no known exploitation of CVE-2018-3831 in the wild and no public exploit code.

## Other vulnerabilities in Elastic Elasticsearch

- [CVE-2015-1427](https://insights.sbomify.com/CVE-2015-1427/): Elasticsearch Groovy Scripting Engine Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2014-3120](https://insights.sbomify.com/CVE-2014-3120/): Elasticsearch Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2015-5377](https://insights.sbomify.com/CVE-2015-5377/): Code injection in n/a (critical 9.8)
- [CVE-2026-72649](https://insights.sbomify.com/CVE-2026-72649/): Deserialization of Untrusted Data in Elasticsearch Leading to Remote Code Execution (high 8.8)
- [CVE-2026-72642](https://insights.sbomify.com/CVE-2026-72642/): Use of Out-of-range Pointer Offset in the Elasticsearch Machine Learning Native Inference Process (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-3831 and fix it if it is affected.

What it is: CVE-2018-3831 is a high-severity vulnerability in Elastic Elasticsearch, published on 19 Sep 2018. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-3831 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.elasticsearch:elasticsearch (Maven): affected from 5.6.0; fixed in 5.6.12
- org.elasticsearch:elasticsearch (Maven): affected from 5.6.0; fixed in 5.6.12
- org.elasticsearch:elasticsearch (Maven): affected from 6.0.0; fixed in 6.4.1
- org.elasticsearch:elasticsearch (Maven): affected from 6.0.0; fixed in 6.4.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-3831/ (Markdown: https://insights.sbomify.com/CVE-2018-3831/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-3831
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-3831
- OSV: https://osv.dev/vulnerability/CVE-2018-3831

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-3831/
Summaries are generated and may contain mistakes; the official description above is the record.
