{"answers":{"affected":"It affects 4 products.","exploited":"There is no known exploitation of CVE-2018-4944 in the wild and no public exploit code.","fix":"Apply the vendor's patch.","what":"CVE-2018-4944 is a critical memory corruption vulnerability in Adobe Flash Player, published on 19 May 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-4944 and fix it if it is affected.\n\nWhat it is: CVE-2018-4944 is a critical memory corruption vulnerability in Adobe Flash Player, published on 19 May 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-4944 in the wild and no public exploit code.\n\nAffected product: Adobe Flash Player. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-4944/ (Markdown: https://insights.sbomify.com/CVE-2018-4944/index.md)","id":"CVE-2018-4944","markdown":"https://insights.sbomify.com/CVE-2018-4944/index.md","name":"CVE-2018-4944","record":{"aliases":["GHSA-w5rc-5jqm-p8hv","MGASA-2018-0233","RHSA-2018:1367","UBUNTU-CVE-2018-4944"],"analysis":{"component_type":"browser","fix_type":"patch","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Adobe Flash Player","requires_auth":"none","summary":"Type confusion in Adobe Flash Player allows arbitrary code execution, requiring users to update to a patched version.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"adobe","cpe":[{"product":"flash_player","vendor":"adobe"},{"product":"enterprise_linux_desktop","vendor":"redhat"},{"product":"enterprise_linux_server","vendor":"redhat"},{"product":"enterprise_linux_workstation","vendor":"redhat"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-704","name":"Incorrect Type Conversion or Cast"}],"description":"Adobe Flash Player versions 29.0.0.140 and earlier have an exploitable type confusion vulnerability. Successful exploitation could lead to arbitrary code execution in the context of the current user.","ecosystems":["Red Hat:rhel_extras:6"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Memory corruption in Adobe Flash Player 29.0.0.140 and earlier versions","id":"CVE-2018-4944","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"adobe:flash_player","products":["adobe:flash_player","redhat:enterprise_linux_desktop","redhat:enterprise_linux_server","redhat:enterprise_linux_workstation"],"type":"memory_corruption","year":"2018"},"n_packages":1,"n_references":5,"next":{"headline":"Memory corruption in Adobe Flash Player 29.0.0.171 and earlier versions","id":"CVE-2018-4945"},"packages":[{"ecosystem":"Red Hat:rhel_extras:6","fixed":["0:29.0.0.171-1.el6_9"],"introduced":["0"],"last_affected":[],"package":"flash-plugin","purl":"pkg:rpm/redhat/flash-plugin","source":"RHSA-2018:1367"}],"prev":{"headline":"Cross-site scripting in Adobe PhoneGap Push Plugin 1.8.0 earlier versions","id":"CVE-2018-4943"},"products":["Adobe Flash Player 29.0.0.140 and earlier versions"],"published":"2018-05-19","related":[{"cvss_score":8.8,"headline":"Adobe Flash Player Type Confusion","id":"CVE-2017-11292","kev_date_added":"2022-03-03","published":"2017-10-21"},{"cvss_score":8.8,"headline":"Adobe Flash Player Use-After-Free","id":"CVE-2016-7892","kev_date_added":"2022-03-25","published":"2016-12-15"},{"cvss_score":8.8,"headline":"Adobe Flash Player Use-After-Free","id":"CVE-2016-7855","kev_date_added":"2022-03-03","published":"2016-11-01"},{"cvss_score":8.8,"headline":"Adobe Flash Player Integer Underflow Vulnerablity","id":"CVE-2014-0497","kev_date_added":"2024-09-17","published":"2014-02-05"},{"cvss_score":8.8,"headline":"Adobe Flash Player Incorrect Default Permissions","id":"CVE-2013-0643","kev_date_added":"2024-09-17","published":"2013-02-27"},{"cvss_score":8.8,"headline":"Adobe Flash Player Code Execution","id":"CVE-2013-0648","kev_date_added":"2024-09-17","published":"2013-02-27"},{"cvss_score":8.8,"headline":"Adobe Flash Player Integer Overflow","id":"CVE-2012-5054","kev_date_added":"2022-06-08","published":"2012-09-24"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"Red Hat","prefix":"RHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Type confusion in Adobe Flash Player allows arbitrary code execution, requiring users to update to a patched version.","url":"https://insights.sbomify.com/CVE-2018-4944/"}