CVE-2018-5223 Command injection in Fisheye and Crucible

High 7.2 Published Updated

An attacker with repository addition permissions can execute arbitrary code on Windows systems by injecting arguments into Mercurial repository URIs.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2018-5223?

CVE-2018-5223 is a high-severity command injection vulnerability in Atlassian Crucible, published on 29 Mar 2018. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

Fisheye and Crucible did not correctly check if a configured Mercurial repository URI contained values that the Windows operating system may consider argument parameters. An attacker who has permission to add a repository in Fisheye or Crucible can execute code of their choice on systems that run a vulnerable version of Fisheye or Crucible on the Windows operating system. All versions of Fisheye and Crucible before 4.4.6 (the fixed version for 4.4.x) and from 4.5.0 before 4.5.3 (the fixed version for 4.5.x) are affected by this vulnerability.

Weakness: CWE-20

Which versions are affected by CVE-2018-5223?

It affects 2 products.

Products include Atlassian Crucible, Atlassian Fisheye.

How do I fix CVE-2018-5223?

No fix has been published for CVE-2018-5223 yet. Limit exposure of the affected software until one is available.

Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.

Is CVE-2018-5223 being exploited?

There is no known exploitation of CVE-2018-5223 in the wild and no public exploit code.

All Atlassian Crucible vulnerabilities

Sources

Also known as GHSA-cmrm-j5wq-2rcr.

Is CVE-2018-5223 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free