CVE-2018-5224 Command injection in Bamboo

High 8.8 Published Updated

An attacker with repository creation or plan editing permissions can execute arbitrary code on Windows servers running Atlassian Bamboo via Mercurial URI injection.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2018-5224?

CVE-2018-5224 is a high-severity command injection vulnerability in Atlassian Bamboo, published on 29 Mar 2018. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Bamboo did not correctly check if a configured Mercurial repository URI contained values that the Windows operating system may consider argument parameters. An attacker who has permission to create a repository in Bamboo, edit an existing plan in Bamboo that has a non-linked Mercurial repository, or create a plan in Bamboo either globally or in a project using Bamboo Specs can can execute code of their choice on systems that run a vulnerable version of Bamboo on the Windows operating system. All versions of Bamboo starting with 2.7.0 before 6.3.3 (the fixed version for 6.3.x) and from version 6.4.0 before 6.4.1 (the fixed version for 6.4.x) running on the Windows operating system are affected by this vulnerability.

Weakness: CWE-20

Which versions are affected by CVE-2018-5224?

It affects 1 product.

Products include Atlassian Bamboo.

How do I fix CVE-2018-5224?

No fix has been published for CVE-2018-5224 yet. Limit exposure of the affected software until one is available.

Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.

Is CVE-2018-5224 being exploited?

There is no known exploitation of CVE-2018-5224 in the wild and no public exploit code.

Sources

Also known as GHSA-5h5c-rh7j-pwpg.

Is CVE-2018-5224 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free