# CVE-2018-5224: Command injection in Bamboo

> An attacker with repository creation or plan editing permissions can execute arbitrary code on Windows servers running Atlassian Bamboo via Mercurial URI injection.

- **Severity:** High 8.8 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 29 Mar 2018
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-5h5c-rh7j-pwpg

## What is CVE-2018-5224?

CVE-2018-5224 is a high-severity command injection vulnerability in Atlassian Bamboo, published on 29 Mar 2018. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Bamboo did not correctly check if a configured Mercurial repository URI contained values that the Windows operating system may consider argument parameters. An attacker who has permission to create a repository in Bamboo, edit an existing plan in Bamboo that has a non-linked Mercurial repository, or create a plan in Bamboo either globally or in a project using Bamboo Specs can can execute code of their choice on systems that run a vulnerable version of Bamboo on the Windows operating system. All versions of Bamboo starting with 2.7.0 before 6.3.3 (the fixed version for 6.3.x) and from version 6.4.0 before 6.4.1 (the fixed version for 6.4.x) running on the Windows operating system are affected by this vulnerability.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2018-5224?

It affects 1 product.


Products: Atlassian Bamboo.

## How do I fix CVE-2018-5224?

No fix has been published for CVE-2018-5224 yet. Limit exposure of the affected software until one is available.

## Is CVE-2018-5224 being exploited?

There is no known exploitation of CVE-2018-5224 in the wild and no public exploit code.

## Other vulnerabilities in Atlassian Bamboo

- [CVE-2026-21589](https://insights.sbomify.com/CVE-2026-21589/): Atlassian Multiple Products Files or Directories Accessible to External Parties (critical 9.3, exploited in the wild)
- [CVE-2022-26136](https://insights.sbomify.com/CVE-2022-26136/): Auth bypass in Bamboo Data Center (critical 9.8)
- [CVE-2016-5229](https://insights.sbomify.com/CVE-2016-5229/): Deserialization in n/a (critical 9.8)
- [CVE-2014-9757](https://insights.sbomify.com/CVE-2014-9757/): Deserialization in n/a (critical 9.8)
- [CVE-2015-8360](https://insights.sbomify.com/CVE-2015-8360/): Deserialization in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-5224 and fix it if it is affected.

What it is: CVE-2018-5224 is a high-severity command injection vulnerability in Atlassian Bamboo, published on 29 Mar 2018. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-5224 in the wild and no public exploit code.

Affected product: Atlassian Bamboo. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-5224/ (Markdown: https://insights.sbomify.com/CVE-2018-5224/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-5224
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-5224
- OSV: https://osv.dev/vulnerability/CVE-2018-5224

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-5224/
Summaries are generated and may contain mistakes; the official description above is the record.
