# CVE-2018-5301: Magento Cross-Site Request Forgery (CSRF)

> Attackers can trick authenticated users into deleting their own address book entries via CSRF, requiring Magento upgrades.

- **Severity:** Medium 6.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 8 Jan 2018
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-w3mq-67mw-3p9f

## What is CVE-2018-5301?

CVE-2018-5301 is a medium-severity vulnerability in Magento Magento, published on 8 Jan 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Magento Community Edition and Enterprise Edition before 2.0.10 and 2.1.x before 2.1.2 have CSRF resulting in deletion of a customer address from an address book, aka APPSEC-1433.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2018-5301?

4 open source packages ship an affected version, including magento/community-edition. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `magento/community-edition` | Packagist | All versions | 2.0.10 |
| `magento/community-edition` | Packagist | All versions | 2.0.10 |
| `magento/community-edition` | Packagist | From 2.1.0 | 2.1.2 |
| `magento/community-edition` | Packagist | From 2.1.0 | 2.1.2 |

Products: Magento Magento.

## How do I fix CVE-2018-5301?

Upgrade magento/community-edition to a fixed version for your release line: 2.0.10 or 2.1.2.

## Is CVE-2018-5301 being exploited?

There is no known exploitation of CVE-2018-5301 in the wild and no public exploit code.

## Other vulnerabilities in Magento Magento

- [CVE-2020-9664](https://insights.sbomify.com/CVE-2020-9664/): Magento php object injection vulnerability (critical 9.8)
- [CVE-2020-9576](https://insights.sbomify.com/CVE-2020-9576/): Magento command injection vulnerability (critical 9.8)
- [CVE-2020-9578](https://insights.sbomify.com/CVE-2020-9578/): Magento command injection vulnerability (critical 9.8)
- [CVE-2020-9579](https://insights.sbomify.com/CVE-2020-9579/): Magento Security mitigation bypass vulnerability (critical 9.8)
- [CVE-2020-9580](https://insights.sbomify.com/CVE-2020-9580/): Magento Security mitigation bypass vulnerability (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-5301 and fix it if it is affected.

What it is: CVE-2018-5301 is a medium-severity vulnerability in Magento Magento, published on 8 Jan 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2018-5301 in the wild and no public exploit code.

Affected packages and fixed versions:
- magento/community-edition (Packagist): affected all versions; fixed in 2.0.10
- magento/community-edition (Packagist): affected all versions; fixed in 2.0.10
- magento/community-edition (Packagist): affected from 2.1.0; fixed in 2.1.2
- magento/community-edition (Packagist): affected from 2.1.0; fixed in 2.1.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-5301/ (Markdown: https://insights.sbomify.com/CVE-2018-5301/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-5301
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-5301
- OSV: https://osv.dev/vulnerability/CVE-2018-5301

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-5301/
Summaries are generated and may contain mistakes; the official description above is the record.
