{"answers":{"affected":"2 open source packages ship an affected version, including wpglobus/wpglobus. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-5361 in the wild and no public exploit code.","fix":"Upgrade wpglobus/wpglobus to 1.9.7 or later.","what":"CVE-2018-5361 is a high-severity vulnerability in n/a, published on 12 Jan 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2018-5361 and fix it if it is affected.\n\nWhat it is: CVE-2018-5361 is a high-severity vulnerability in n/a, published on 12 Jan 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2018-5361 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- wpglobus/wpglobus (Packagist): affected all versions; fixed in 1.9.7\n- wpglobus/wpglobus (Packagist): affected all versions; fixed in 1.9.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-5361/ (Markdown: https://insights.sbomify.com/CVE-2018-5361/index.md)","id":"CVE-2018-5361","markdown":"https://insights.sbomify.com/CVE-2018-5361/index.md","name":"CVE-2018-5361","record":{"aliases":["GHSA-6fxc-v8wq-849g"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress plugin","requires_auth":"none","summary":"Cross-site request forgery in WPGlobus plugin allows attackers to modify WordPress settings via options.php.","user_interaction":"required","vuln_class":"csrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"wpglobus","vendor":"wpglobus"}],"cvss":{"score":8.8,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-352","name":"Cross-Site Request Forgery"}],"description":"The WPGlobus plugin 1.9.6 for WordPress has CSRF via wp-admin/options.php.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"WPGlobus plugin Stored XSS \u0026 CSRF security vulnerability","id":"CVE-2018-5361","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"csrf","year":"2018"},"n_packages":2,"n_references":2,"next":{"headline":"WPGlobus plugin Stored XSS \u0026 CSRF security vulnerability","id":"CVE-2018-5362"},"packages":[{"ecosystem":"Packagist","fixed":["1.9.7"],"introduced":["0"],"last_affected":[],"package":"wpglobus/wpglobus","purl":null,"source":"GHSA-6fxc-v8wq-849g"},{"ecosystem":"Packagist","fixed":["1.9.7"],"introduced":["0"],"last_affected":[],"package":"wpglobus/wpglobus","purl":"pkg:composer/wpglobus/wpglobus","source":"GHSA-6fxc-v8wq-849g"}],"prev":{"headline":"Memory corruption in n/a","id":"CVE-2018-5360"},"products":["n/a"],"published":"2018-01-12","related":[{"cvss_score":4.8,"headline":"WPGlobus plugin Stored XSS \u0026 CSRF security vulnerability","id":"CVE-2018-5362","kev_date_added":null,"published":"2018-01-12"},{"cvss_score":4.8,"headline":"WPGlobus plugin Stored XSS \u0026 CSRF security vulnerability","id":"CVE-2018-5363","kev_date_added":null,"published":"2018-01-12"},{"cvss_score":4.8,"headline":"WPGlobus plugin Stored XSS \u0026 CSRF security vulnerability","id":"CVE-2018-5364","kev_date_added":null,"published":"2018-01-12"},{"cvss_score":4.8,"headline":"WPGlobus plugin Stored XSS \u0026 CSRF security vulnerability","id":"CVE-2018-5365","kev_date_added":null,"published":"2018-01-12"},{"cvss_score":4.8,"headline":"WPGlobus plugin Stored XSS \u0026 CSRF security vulnerability","id":"CVE-2018-5366","kev_date_added":null,"published":"2018-01-12"},{"cvss_score":4.8,"headline":"WPGlobus plugin Stored XSS \u0026 CSRF security vulnerability","id":"CVE-2018-5367","kev_date_added":null,"published":"2018-01-12"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Cross-site request forgery in WPGlobus plugin allows attackers to modify WordPress settings via options.php.","url":"https://insights.sbomify.com/CVE-2018-5361/"}