# CVE-2018-5364: WPGlobus plugin Stored XSS & CSRF security vulnerability

> Cross-site scripting vulnerability in WPGlobus plugin allows attackers to inject malicious scripts via the browser redirect language parameter.

- **Severity:** Medium 4.8 (`CVSS:3.0/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 12 Jan 2018
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-v9h6-53fx-gh4j

## What is CVE-2018-5364?

CVE-2018-5364 is a medium-severity cross-site scripting vulnerability in n/a, published on 12 Jan 2018. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

The WPGlobus plugin 1.9.6 for WordPress has XSS via the wpglobus_option[browser_redirect][redirect_by_language] parameter to wp-admin/options.php.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2018-5364?

2 open source packages ship an affected version, including wpglobus/wpglobus. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `wpglobus/wpglobus` | Packagist | All versions | 1.9.7 |
| `wpglobus/wpglobus` | Packagist | All versions | 1.9.7 |

Products: Wpglobus Wpglobus.

## How do I fix CVE-2018-5364?

Upgrade wpglobus/wpglobus to 1.9.7 or later.

## Is CVE-2018-5364 being exploited?

There is no known exploitation of CVE-2018-5364 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2018-5361](https://insights.sbomify.com/CVE-2018-5361/): WPGlobus plugin Stored XSS & CSRF security vulnerability (high 8.8)
- [CVE-2018-5362](https://insights.sbomify.com/CVE-2018-5362/): WPGlobus plugin Stored XSS & CSRF security vulnerability (medium 4.8)
- [CVE-2018-5363](https://insights.sbomify.com/CVE-2018-5363/): WPGlobus plugin Stored XSS & CSRF security vulnerability (medium 4.8)
- [CVE-2018-5365](https://insights.sbomify.com/CVE-2018-5365/): WPGlobus plugin Stored XSS & CSRF security vulnerability (medium 4.8)
- [CVE-2018-5366](https://insights.sbomify.com/CVE-2018-5366/): WPGlobus plugin Stored XSS & CSRF security vulnerability (medium 4.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-5364 and fix it if it is affected.

What it is: CVE-2018-5364 is a medium-severity cross-site scripting vulnerability in n/a, published on 12 Jan 2018. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2018-5364 in the wild and no public exploit code.

Affected packages and fixed versions:
- wpglobus/wpglobus (Packagist): affected all versions; fixed in 1.9.7
- wpglobus/wpglobus (Packagist): affected all versions; fixed in 1.9.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-5364/ (Markdown: https://insights.sbomify.com/CVE-2018-5364/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-5364
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-5364
- OSV: https://osv.dev/vulnerability/CVE-2018-5364

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-5364/
Summaries are generated and may contain mistakes; the official description above is the record.
