{"answers":{"affected":"It affects 9 products.","exploited":"There is no known exploitation of CVE-2018-5379 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2018-5379 is a high-severity use after free vulnerability in Canonical Ubuntu Linux, published on 19 Feb 2018. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-5379 and fix it if it is affected.\n\nWhat it is: CVE-2018-5379 is a high-severity use after free vulnerability in Canonical Ubuntu Linux, published on 19 Feb 2018. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-5379 in the wild and no public exploit code.\n\nAffected product: Canonical Ubuntu Linux. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-5379/ (Markdown: https://insights.sbomify.com/CVE-2018-5379/index.md)","id":"CVE-2018-5379","markdown":"https://insights.sbomify.com/CVE-2018-5379/index.md","name":"CVE-2018-5379","record":{"aliases":["CVE-2018-1000063","GHSA-5prq-47x2-38gv","RHSA-2018:0377","UBUNTU-CVE-2018-5379"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service","code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Quagga BGP daemon","requires_auth":"low_privilege","summary":"A double-free vulnerability in the Quagga BGP daemon allows remote attackers to cause a denial of service or execute arbitrary code via crafted UPDATE messages.","user_interaction":"not_required","vuln_class":"use_after_free"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"certcc","cpe":[{"product":"ubuntu_linux","vendor":"canonical"},{"product":"debian_linux","vendor":"debian"},{"product":"quagga","vendor":"quagga"},{"product":"enterprise_linux_server","vendor":"redhat"},{"product":"enterprise_linux_server_aus","vendor":"redhat"},{"product":"enterprise_linux_server_eus","vendor":"redhat"},{"product":"enterprise_linux_server_tus","vendor":"redhat"},{"product":"enterprise_linux_workstation","vendor":"redhat"},{"product":"ruggedcom_rox_ii_firmware","vendor":"siemens"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-415","name":"Double Free"}],"description":"The Quagga BGP daemon (bgpd) prior to version 1.2.3 can double-free memory when processing certain forms of UPDATE message, containing cluster-list and/or unknown attributes. A successful attack could cause a denial of service or potentially allow an attacker to execute arbitrary code.","ecosystems":["Red Hat:enterprise_linux:7::server","Red Hat:enterprise_linux:7::workstation"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Use after free in bgpd","id":"CVE-2018-5379","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"canonical:ubuntu_linux","products":["canonical:ubuntu_linux","debian:debian_linux","redhat:enterprise_linux_server","redhat:enterprise_linux_server_aus","redhat:enterprise_linux_server_eus","redhat:enterprise_linux_server_tus","redhat:enterprise_linux_workstation"],"type":"use_after_free","year":"2018"},"n_packages":8,"n_references":10,"next":{"headline":"Memory corruption in bgpd","id":"CVE-2018-5380"},"packages":[{"ecosystem":"Red Hat:enterprise_linux:7::server","fixed":["0:0.99.22.4-5.el7_4"],"introduced":["0"],"last_affected":[],"package":"quagga","purl":"pkg:rpm/redhat/quagga","source":"RHSA-2018:0377"},{"ecosystem":"Red Hat:enterprise_linux:7::server","fixed":["0:0.99.22.4-5.el7_4"],"introduced":["0"],"last_affected":[],"package":"quagga-contrib","purl":"pkg:rpm/redhat/quagga-contrib","source":"RHSA-2018:0377"},{"ecosystem":"Red Hat:enterprise_linux:7::server","fixed":["0:0.99.22.4-5.el7_4"],"introduced":["0"],"last_affected":[],"package":"quagga-debuginfo","purl":"pkg:rpm/redhat/quagga-debuginfo","source":"RHSA-2018:0377"},{"ecosystem":"Red Hat:enterprise_linux:7::server","fixed":["0:0.99.22.4-5.el7_4"],"introduced":["0"],"last_affected":[],"package":"quagga-devel","purl":"pkg:rpm/redhat/quagga-devel","source":"RHSA-2018:0377"},{"ecosystem":"Red Hat:enterprise_linux:7::workstation","fixed":["0:0.99.22.4-5.el7_4"],"introduced":["0"],"last_affected":[],"package":"quagga","purl":"pkg:rpm/redhat/quagga","source":"RHSA-2018:0377"},{"ecosystem":"Red Hat:enterprise_linux:7::workstation","fixed":["0:0.99.22.4-5.el7_4"],"introduced":["0"],"last_affected":[],"package":"quagga-contrib","purl":"pkg:rpm/redhat/quagga-contrib","source":"RHSA-2018:0377"},{"ecosystem":"Red Hat:enterprise_linux:7::workstation","fixed":["0:0.99.22.4-5.el7_4"],"introduced":["0"],"last_affected":[],"package":"quagga-debuginfo","purl":"pkg:rpm/redhat/quagga-debuginfo","source":"RHSA-2018:0377"},{"ecosystem":"Red Hat:enterprise_linux:7::workstation","fixed":["0:0.99.22.4-5.el7_4"],"introduced":["0"],"last_affected":[],"package":"quagga-devel","purl":"pkg:rpm/redhat/quagga-devel","source":"RHSA-2018:0377"}],"prev":{"headline":"Information disclosure in bgpd","id":"CVE-2018-5378"},"products":["bgpd"],"published":"2018-02-19","related":[{"cvss_score":9.8,"headline":"SaltStack Salt Authentication Bypass","id":"CVE-2020-11651","kev_date_added":"2021-11-03","published":"2020-04-30"},{"cvss_score":9.8,"headline":"OpenSMTPD Remote Code Execution","id":"CVE-2020-7247","kev_date_added":"2022-03-25","published":"2020-01-29"},{"cvss_score":9.8,"headline":"Exim Out-of-bounds Write","id":"CVE-2019-16928","kev_date_added":"2022-03-03","published":"2019-09-27"},{"cvss_score":9.8,"headline":"Exim Buffer Overflow","id":"CVE-2018-6789","kev_date_added":"2021-11-03","published":"2018-02-08"},{"cvss_score":9.8,"headline":"Oracle Java SE and Java SE Embedded Remote Code Execution","id":"CVE-2015-2590","kev_date_added":"2022-03-03","published":"2015-07-16"},{"cvss_score":9.8,"headline":"Oracle JRE Remote Code Execution","id":"CVE-2013-0422","kev_date_added":"2022-05-25","published":"2013-01-10"},{"cvss_score":9.8,"headline":"Oracle Java SE Runtime Environment (JRE) Arbitrary Code Execution","id":"CVE-2011-3544","kev_date_added":"2022-03-03","published":"2011-10-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"Red Hat","prefix":"RHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-17","vendors":["Quagga"]},"summary":"A double-free vulnerability in the Quagga BGP daemon allows remote attackers to cause a denial of service or execute arbitrary code via crafted UPDATE messages.","url":"https://insights.sbomify.com/CVE-2018-5379/"}