# CVE-2018-5387: Wizkunde SAMLBase SAML Bypass

> Attackers can bypass SAML authentication by manipulating XML data without invalidating signatures, potentially gaining unauthorized access to service providers.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Jul 2018
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-7gh2-8q93-87hp

## What is CVE-2018-5387?

CVE-2018-5387 is a high-severity authentication bypass vulnerability in Wizkunde SAMLBase, published on 24 Jul 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Wizkunde SAMLBase may incorrectly utilize the results of XML DOM traversal and canonicalization APIs in such a way that an attacker may be able to manipulate the SAML data without invalidating the cryptographic signature, allowing the attack to potentially bypass authentication to SAML service providers.

Weakness: CWE-347 (Improper Verification of Cryptographic Signature), CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2018-5387?

2 open source packages ship an affected version, including gogentooss/samlbase. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gogentooss/samlbase` | Packagist | All versions | 1.2.7 |
| `gogentooss/samlbase` | Packagist | All versions | 1.2.7 |

Products: Wizkunde Samlbase.

## How do I fix CVE-2018-5387?

Upgrade gogentooss/samlbase to 1.2.7 or later.

## Is CVE-2018-5387 being exploited?

There is no known exploitation of CVE-2018-5387 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-5387 and fix it if it is affected.

What it is: CVE-2018-5387 is a high-severity authentication bypass vulnerability in Wizkunde SAMLBase, published on 24 Jul 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-5387 in the wild and no public exploit code.

Affected packages and fixed versions:
- gogentooss/samlbase (Packagist): affected all versions; fixed in 1.2.7
- gogentooss/samlbase (Packagist): affected all versions; fixed in 1.2.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-5387/ (Markdown: https://insights.sbomify.com/CVE-2018-5387/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-5387
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-5387
- OSV: https://osv.dev/vulnerability/CVE-2018-5387

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-5387/
Summaries are generated and may contain mistakes; the official description above is the record.
