{"answers":{"affected":"3 open source packages ship an affected version, including markdown2. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-5773 in the wild and no public exploit code.","fix":"Upgrade markdown2 to 2.3.6 or later.","what":"CVE-2018-5773 is a medium-severity cross-site scripting vulnerability in n/a, published on 18 Jan 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2018-5773 and fix it if it is affected.\n\nWhat it is: CVE-2018-5773 is a medium-severity cross-site scripting vulnerability in n/a, published on 18 Jan 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2018-5773 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- markdown2 (PyPI): affected all versions; fixed in 2.3.6\n- markdown2 (PyPI): affected all versions; fixed in 2.3.6\n- markdown2 (PyPI): affected all versions; fixed in 2.3.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-5773/ (Markdown: https://insights.sbomify.com/CVE-2018-5773/index.md)","id":"CVE-2018-5773","markdown":"https://insights.sbomify.com/CVE-2018-5773/index.md","name":"CVE-2018-5773","record":{"aliases":["GHSA-p6h9-gw49-rqm4","PYSEC-2018-13"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"Python markdown library","requires_auth":"none","summary":"Attackers can execute arbitrary scripts via crafted input when the safe_mode feature is enabled in the markdown2 library.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"python-markdown2","vendor":"python-markdown2_project"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"An issue was discovered in markdown2 (aka python-markdown2) through 2.3.5. The safe_mode feature, which is supposed to sanitize user input against XSS, is flawed and does not escape the input properly. With a crafted payload, XSS can be triggered, as demonstrated by omitting the final '\u003e' character from an IMG tag.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"markdown2 is vulnerable to cross-site scripting","id":"CVE-2018-5773","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"xss","year":"2018"},"n_packages":3,"n_references":1,"next":{"headline":"Cross-site scripting in n/a","id":"CVE-2018-5776"},"packages":[{"ecosystem":"PyPI","fixed":["2.3.6"],"introduced":["0"],"last_affected":[],"package":"markdown2","purl":null,"source":"GHSA-p6h9-gw49-rqm4"},{"ecosystem":"PyPI","fixed":["2.3.6"],"introduced":["0"],"last_affected":[],"package":"markdown2","purl":"pkg:pypi/markdown2","source":"GHSA-p6h9-gw49-rqm4"},{"ecosystem":"PyPI","fixed":["2.3.6"],"introduced":["0"],"last_affected":[],"package":"markdown2","purl":"pkg:pypi/markdown2","source":"PYSEC-2018-13"}],"prev":{"headline":"Denial of service in n/a","id":"CVE-2018-5772"},"products":["n/a"],"published":"2018-01-18","related":[{"cvss_score":6.1,"headline":"XSS in python-markdown2","id":"CVE-2020-11888","kev_date_added":null,"published":"2020-04-20"},{"cvss_score":6.1,"headline":"Cross-site scripting in markdown2 for python","id":"CVE-2009-3724","kev_date_added":null,"published":"2020-01-15"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["n/a"]},"summary":"Attackers can execute arbitrary scripts via crafted input when the safe_mode feature is enabled in the markdown2 library.","url":"https://insights.sbomify.com/CVE-2018-5773/"}