# CVE-2018-5773: markdown2 is vulnerable to cross-site scripting

> Attackers can execute arbitrary scripts via crafted input when the safe_mode feature is enabled in the markdown2 library.

- **Severity:** Medium 6.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 18 Jan 2018
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-p6h9-gw49-rqm4, PYSEC-2018-13

## What is CVE-2018-5773?

CVE-2018-5773 is a medium-severity cross-site scripting vulnerability in n/a, published on 18 Jan 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

An issue was discovered in markdown2 (aka python-markdown2) through 2.3.5. The safe_mode feature, which is supposed to sanitize user input against XSS, is flawed and does not escape the input properly. With a crafted payload, XSS can be triggered, as demonstrated by omitting the final '>' character from an IMG tag.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2018-5773?

3 open source packages ship an affected version, including markdown2. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `markdown2` | PyPI | All versions | 2.3.6 |
| `markdown2` | PyPI | All versions | 2.3.6 |
| `markdown2` | PyPI | All versions | 2.3.6 |

Products: Python-Markdown2 Project Python-Markdown2.

## How do I fix CVE-2018-5773?

Upgrade markdown2 to 2.3.6 or later.

## Is CVE-2018-5773 being exploited?

There is no known exploitation of CVE-2018-5773 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2020-11888](https://insights.sbomify.com/CVE-2020-11888/): XSS in python-markdown2 (medium 6.1)
- [CVE-2009-3724](https://insights.sbomify.com/CVE-2009-3724/): Cross-site scripting in markdown2 for python (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-5773 and fix it if it is affected.

What it is: CVE-2018-5773 is a medium-severity cross-site scripting vulnerability in n/a, published on 18 Jan 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2018-5773 in the wild and no public exploit code.

Affected packages and fixed versions:
- markdown2 (PyPI): affected all versions; fixed in 2.3.6
- markdown2 (PyPI): affected all versions; fixed in 2.3.6
- markdown2 (PyPI): affected all versions; fixed in 2.3.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-5773/ (Markdown: https://insights.sbomify.com/CVE-2018-5773/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-5773
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-5773
- OSV: https://osv.dev/vulnerability/CVE-2018-5773

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-5773/
Summaries are generated and may contain mistakes; the official description above is the record.
