CVE-2018-5968 Deserialization of Untrusted Data in jackson-databind

High 8.1 Published Updated

Unauthenticated remote attackers can execute arbitrary code via unsafe deserialization in jackson-databind, bypassing previous blacklist fixes.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2018-5968?

CVE-2018-5968 is a high-severity unsafe deserialization vulnerability in Debian Debian Linux, published on 22 Jan 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

FasterXML jackson-databind through 2.8.11 and 2.9.x through 2.9.3 allows unauthenticated remote code execution because of an incomplete fix for the CVE-2017-7525 and CVE-2017-17485 deserialization flaws. This is exploitable via two different gadgets that bypass a blacklist.

Weakness: CWE-502, CWE-184

Which versions are affected by CVE-2018-5968?

6 open source packages ship an affected version, including com.fasterxml.jackson.core:jackson-databind. It affects 9 products.

PackageAffectedFixed in
com.fasterxml.jackson.core:jackson-databind MavenAll versions2.7.9.5
com.fasterxml.jackson.core:jackson-databind MavenAll versions2.7.9.5
com.fasterxml.jackson.core:jackson-databind MavenFrom 2.8.02.8.11.1
com.fasterxml.jackson.core:jackson-databind MavenFrom 2.8.02.8.11.1
com.fasterxml.jackson.core:jackson-databind MavenFrom 2.9.02.9.4
com.fasterxml.jackson.core:jackson-databind MavenFrom 2.9.02.9.4

Products include Debian Debian Linux, Fasterxml Jackson-Databind, Netapp E-Series Santricity Os Controller, Netapp E-Series Santricity Web Services Proxy, Netapp Oncommand Shift, Redhat Jboss Enterprise Application Platform and 3 more.

How do I fix CVE-2018-5968?

Upgrade com.fasterxml.jackson.core:jackson-databind to a fixed version for your release line: 2.7.9.5, 2.8.11.1 or 2.9.4.

Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.

Is CVE-2018-5968 being exploited?

There is no known exploitation of CVE-2018-5968 in the wild and no public exploit code.

All Debian Debian Linux vulnerabilities

Sources

Also known as CLEANSTART-2026-JL35861, DEBIAN-CVE-2018-5968, GHSA-w3f4-3q6j-rh82, ROOT-APP-MAVEN-CVE-2018-5968, UBUNTU-CVE-2018-5968.

Is CVE-2018-5968 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free