# CVE-2018-5968: Deserialization of Untrusted Data in jackson-databind

> Unauthenticated remote attackers can execute arbitrary code via unsafe deserialization in jackson-databind, bypassing previous blacklist fixes.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Jan 2018
- **Updated:** 8 Oct 2026
- **Also known as:** CLEANSTART-2026-JL35861, DEBIAN-CVE-2018-5968, GHSA-w3f4-3q6j-rh82, ROOT-APP-MAVEN-CVE-2018-5968, UBUNTU-CVE-2018-5968

## What is CVE-2018-5968?

CVE-2018-5968 is a high-severity unsafe deserialization vulnerability in Debian Debian Linux, published on 22 Jan 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

FasterXML jackson-databind through 2.8.11 and 2.9.x through 2.9.3 allows unauthenticated remote code execution because of an incomplete fix for the CVE-2017-7525 and CVE-2017-17485 deserialization flaws. This is exploitable via two different gadgets that bypass a blacklist.

Weakness: CWE-502 (Deserialization of Untrusted Data), CWE-184 (Incomplete List of Disallowed Inputs)

## Which versions are affected by CVE-2018-5968?

6 open source packages ship an affected version, including com.fasterxml.jackson.core:jackson-databind. It affects 9 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.fasterxml.jackson.core:jackson-databind` | Maven | All versions | 2.7.9.5 |
| `com.fasterxml.jackson.core:jackson-databind` | Maven | All versions | 2.7.9.5 |
| `com.fasterxml.jackson.core:jackson-databind` | Maven | From 2.8.0 | 2.8.11.1 |
| `com.fasterxml.jackson.core:jackson-databind` | Maven | From 2.8.0 | 2.8.11.1 |
| `com.fasterxml.jackson.core:jackson-databind` | Maven | From 2.9.0 | 2.9.4 |
| `com.fasterxml.jackson.core:jackson-databind` | Maven | From 2.9.0 | 2.9.4 |

Products: Debian Debian Linux, Fasterxml Jackson-Databind, Netapp E-Series Santricity Os Controller, Netapp E-Series Santricity Web Services Proxy, Netapp Oncommand Shift, Redhat Jboss Enterprise Application Platform, Redhat Openshift Container Platform, Redhat Virtualization, Redhat Virtualization Host.

## How do I fix CVE-2018-5968?

Upgrade com.fasterxml.jackson.core:jackson-databind to a fixed version for your release line: 2.7.9.5, 2.8.11.1 or 2.9.4.

## Is CVE-2018-5968 being exploited?

There is no known exploitation of CVE-2018-5968 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-5968 and fix it if it is affected.

What it is: CVE-2018-5968 is a high-severity unsafe deserialization vulnerability in Debian Debian Linux, published on 22 Jan 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-5968 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.fasterxml.jackson.core:jackson-databind (Maven): affected all versions; fixed in 2.7.9.5
- com.fasterxml.jackson.core:jackson-databind (Maven): affected all versions; fixed in 2.7.9.5
- com.fasterxml.jackson.core:jackson-databind (Maven): affected from 2.8.0; fixed in 2.8.11.1
- com.fasterxml.jackson.core:jackson-databind (Maven): affected from 2.8.0; fixed in 2.8.11.1
- com.fasterxml.jackson.core:jackson-databind (Maven): affected from 2.9.0; fixed in 2.9.4
- com.fasterxml.jackson.core:jackson-databind (Maven): affected from 2.9.0; fixed in 2.9.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-5968/ (Markdown: https://insights.sbomify.com/CVE-2018-5968/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-5968
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-5968
- OSV: https://osv.dev/vulnerability/CVE-2018-5968

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-5968/
Summaries are generated and may contain mistakes; the official description above is the record.
