{"answers":{"affected":"It affects 3 products.","exploited":"There is no known exploitation of CVE-2018-6003 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2018-6003 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 22 Jan 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-6003 and fix it if it is affected.\n\nWhat it is: CVE-2018-6003 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 22 Jan 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-6003 in the wild and no public exploit code.\n\nAffected product: Debian Debian Linux. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-6003/ (Markdown: https://insights.sbomify.com/CVE-2018-6003/index.md)","id":"CVE-2018-6003","markdown":"https://insights.sbomify.com/CVE-2018-6003/index.md","name":"CVE-2018-6003","record":{"aliases":["ALPINE-CVE-2018-6003","CLSA-2026-1778604436","DEBIAN-CVE-2018-6003","GHSA-834w-g79f-wrqv","SUSE-SU-2018:0295-1","UBUNTU-CVE-2018-6003"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"ASN.1 decoding library","requires_auth":"none","summary":"Attackers can cause a denial of service via stack exhaustion in the BER decoder of the Libtasn1 library.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"debian_linux","vendor":"debian"},{"product":"fedora","vendor":"fedoraproject"},{"product":"libtasn1","vendor":"gnu"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-674","name":"Uncontrolled Recursion"}],"description":"An issue was discovered in the _asn1_decode_simple_ber function in decoding.c in GNU Libtasn1 before 4.13. Unlimited recursion in the BER decoder leads to stack exhaustion and DoS.","ecosystems":["SUSE:Linux Enterprise Desktop 12 SP3","SUSE:Linux Enterprise Server 12 SP3","SUSE:Linux Enterprise Server for SAP Applications 12 SP3","SUSE:Linux Enterprise Software Development Kit 12 SP3"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Denial of service in n/a","id":"CVE-2018-6003","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"debian:debian_linux","products":["debian:debian_linux","fedoraproject:fedora"],"type":"denial_of_service","year":"2018"},"n_packages":4,"n_references":7,"next":{"headline":"SQL injection in n/a","id":"CVE-2018-6004"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Desktop 12 SP3","fixed":["4.9-3.5.1"],"introduced":["0"],"last_affected":[],"package":"libtasn1","purl":"pkg:rpm/suse/libtasn1\u0026distro=SUSE%20Linux%20Enterprise%20Desktop%2012%20SP3","source":"SUSE-SU-2018:0295-1"},{"ecosystem":"SUSE:Linux Enterprise Server 12 SP3","fixed":["4.9-3.5.1"],"introduced":["0"],"last_affected":[],"package":"libtasn1","purl":"pkg:rpm/suse/libtasn1\u0026distro=SUSE%20Linux%20Enterprise%20Server%2012%20SP3","source":"SUSE-SU-2018:0295-1"},{"ecosystem":"SUSE:Linux Enterprise Server for SAP Applications 12 SP3","fixed":["4.9-3.5.1"],"introduced":["0"],"last_affected":[],"package":"libtasn1","purl":"pkg:rpm/suse/libtasn1\u0026distro=SUSE%20Linux%20Enterprise%20Server%20for%20SAP%20Applications%2012%20SP3","source":"SUSE-SU-2018:0295-1"},{"ecosystem":"SUSE:Linux Enterprise Software Development Kit 12 SP3","fixed":["4.9-3.5.1"],"introduced":["0"],"last_affected":[],"package":"libtasn1","purl":"pkg:rpm/suse/libtasn1\u0026distro=SUSE%20Linux%20Enterprise%20Software%20Development%20Kit%2012%20SP3","source":"SUSE-SU-2018:0295-1"}],"prev":{"headline":"Cross-site scripting in n/a","id":"CVE-2018-6002"},"products":["n/a"],"published":"2018-01-22","related":[{"cvss_score":10,"headline":"ProFTPD Improper Access Control","id":"CVE-2015-3306","kev_date_added":"2026-10-08","published":"2015-05-18"},{"cvss_score":9.9,"headline":"RoundCube Webmail Deserialization of Untrusted Data","id":"CVE-2025-49113","kev_date_added":"2026-02-20","published":"2025-06-02"},{"cvss_score":9.8,"headline":"GNU InetUtils Argument Injection","id":"CVE-2026-24061","kev_date_added":"2026-01-26","published":"2026-01-21"},{"cvss_score":9.8,"headline":"Linux Kernel Improper Check for Unusual or Exceptional Conditions","id":"CVE-2025-39682","kev_date_added":"2026-09-18","published":"2025-09-05"},{"cvss_score":9.8,"headline":"Mozilla Firefox Use-After-Free","id":"CVE-2024-9680","kev_date_added":"2024-10-15","published":"2024-10-09"},{"cvss_score":9.8,"headline":"RARLAB UnRAR Directory Traversal","id":"CVE-2022-30333","kev_date_added":"2022-08-09","published":"2022-05-09"},{"cvss_score":9.8,"headline":"Roundcube Webmail SQL Injection","id":"CVE-2021-44026","kev_date_added":"2023-06-22","published":"2021-11-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Attackers can cause a denial of service via stack exhaustion in the BER decoder of the Libtasn1 library.","url":"https://insights.sbomify.com/CVE-2018-6003/"}