{"answers":{"affected":"4 open source packages ship an affected version, including yiisoft/yii2 and yiisoft/yii2-dev. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-6009 in the wild and no public exploit code.","fix":"Upgrade yiisoft/yii2 to 2.0.14 or later.","what":"CVE-2018-6009 is a high-severity vulnerability in n/a, published on 22 Jan 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2018-6009 and fix it if it is affected.\n\nWhat it is: CVE-2018-6009 is a high-severity vulnerability in n/a, published on 22 Jan 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2018-6009 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- yiisoft/yii2 (Packagist): affected from 2.0; fixed in 2.0.14\n- yiisoft/yii2 (Packagist): affected from 2.0; fixed in 2.0.14\n- yiisoft/yii2-dev (Packagist): affected from 2.0; fixed in 2.0.14\n- yiisoft/yii2-dev (Packagist): affected from 2.0; fixed in 2.0.14\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-6009/ (Markdown: https://insights.sbomify.com/CVE-2018-6009/index.md)","id":"CVE-2018-6009","markdown":"https://insights.sbomify.com/CVE-2018-6009/index.md","name":"CVE-2018-6009","record":{"aliases":["GHSA-cwhm-272p-3wj9"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Yii Framework","requires_auth":"none","summary":"Attackers can bypass CSRF protection during identity switches in Yii Framework, potentially allowing unauthorized actions on behalf of authenticated users.","user_interaction":"required","vuln_class":"csrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"yiiframework","vendor":"yiiframework"}],"cvss":{"score":8.8,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-352","name":"Cross-Site Request Forgery"}],"description":"In Yii Framework 2.x before 2.0.14, the switchIdentity function in web/User.php did not regenerate the CSRF token upon a change of identity.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Yii Framework Cross-Site Request Forgery (CSRF)","id":"CVE-2018-6009","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"csrf","year":"2018"},"n_packages":4,"n_references":1,"next":{"headline":"Yii Framework reflected Cross-site Scripting","id":"CVE-2018-6010"},"packages":[{"ecosystem":"Packagist","fixed":["2.0.14"],"introduced":["2.0"],"last_affected":[],"package":"yiisoft/yii2","purl":null,"source":"GHSA-cwhm-272p-3wj9"},{"ecosystem":"Packagist","fixed":["2.0.14"],"introduced":["2.0"],"last_affected":[],"package":"yiisoft/yii2","purl":"pkg:composer/yiisoft/yii2","source":"GHSA-cwhm-272p-3wj9"},{"ecosystem":"Packagist","fixed":["2.0.14"],"introduced":["2.0"],"last_affected":[],"package":"yiisoft/yii2-dev","purl":null,"source":"GHSA-cwhm-272p-3wj9"},{"ecosystem":"Packagist","fixed":["2.0.14"],"introduced":["2.0"],"last_affected":[],"package":"yiisoft/yii2-dev","purl":"pkg:composer/yiisoft/yii2-dev","source":"GHSA-cwhm-272p-3wj9"}],"prev":{"headline":"Path traversal in n/a","id":"CVE-2018-6008"},"products":["n/a"],"published":"2018-01-22","related":[{"cvss_score":7.5,"headline":"Yii Framework reflected Cross-site Scripting","id":"CVE-2018-6010","kev_date_added":null,"published":"2018-01-22"},{"cvss_score":7.5,"headline":"Yii PHP Framework arbitrary PHP scripts execution","id":"CVE-2014-4672","kev_date_added":null,"published":"2014-07-03"},{"cvss_score":4.3,"headline":"Yii Framework Cross-site Scripting Vulnerability","id":"CVE-2015-3397","kev_date_added":null,"published":"2015-05-14"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Attackers can bypass CSRF protection during identity switches in Yii Framework, potentially allowing unauthorized actions on behalf of authenticated users.","url":"https://insights.sbomify.com/CVE-2018-6009/"}