# CVE-2018-6010: Yii Framework reflected Cross-site Scripting

> Attackers can exploit reflected XSS and leak sensitive information via exception messages in the Yii Framework error handler.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Jan 2018
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-8gfq-c54m-3rf6

## What is CVE-2018-6010?

CVE-2018-6010 is a high-severity cross-site scripting vulnerability in n/a, published on 22 Jan 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In Yii Framework 2.x before 2.0.14, remote attackers could obtain potentially sensitive information from exception messages, or exploit reflected XSS on the error handler page in non-debug mode. Related to base/ErrorHandler.php, log/Dispatcher.php, and views/errorHandler/exception.php.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2018-6010?

2 open source packages ship an affected version, including yiisoft/yii2. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `yiisoft/yii2` | Packagist | From 2.0.0 | 2.0.14 |
| `yiisoft/yii2` | Packagist | From 2.0.0 | 2.0.14 |

Products: Yiiframework Yiiframework.

## How do I fix CVE-2018-6010?

Upgrade yiisoft/yii2 to 2.0.14 or later.

## Is CVE-2018-6010 being exploited?

There is no known exploitation of CVE-2018-6010 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2018-6009](https://insights.sbomify.com/CVE-2018-6009/): Yii Framework Cross-Site Request Forgery (CSRF) (high 8.8)
- [CVE-2014-4672](https://insights.sbomify.com/CVE-2014-4672/): Yii PHP Framework arbitrary PHP scripts execution (high 7.5)
- [CVE-2015-3397](https://insights.sbomify.com/CVE-2015-3397/): Yii Framework Cross-site Scripting Vulnerability (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-6010 and fix it if it is affected.

What it is: CVE-2018-6010 is a high-severity cross-site scripting vulnerability in n/a, published on 22 Jan 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-6010 in the wild and no public exploit code.

Affected packages and fixed versions:
- yiisoft/yii2 (Packagist): affected from 2.0.0; fixed in 2.0.14
- yiisoft/yii2 (Packagist): affected from 2.0.0; fixed in 2.0.14

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-6010/ (Markdown: https://insights.sbomify.com/CVE-2018-6010/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-6010
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-6010
- OSV: https://osv.dev/vulnerability/CVE-2018-6010

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-6010/
Summaries are generated and may contain mistakes; the official description above is the record.
