# CVE-2018-6184: Directory traversal vulnerability in Next.js

> Attackers can read arbitrary files via directory traversal in the Next.js framework, requiring an upgrade to secure the application.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Jan 2018
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-m34x-wgrh-g897

## What is CVE-2018-6184?

CVE-2018-6184 is a high-severity path traversal vulnerability in n/a, published on 24 Jan 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

ZEIT Next.js 4 before 4.2.3 has Directory Traversal under the /_next request namespace.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2018-6184?

2 open source packages ship an affected version, including next. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `next` | npm | From 1.0.0 | 4.2.3 |
| `next` | npm | From 1.0.0 | 4.2.3 |

Products: Zeit Next.js.

## How do I fix CVE-2018-6184?

Upgrade next to 4.2.3 or later.

## Is CVE-2018-6184 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2018-6184 exists.

Public exploit code:

- Zeit Next.js < 4.2.3 - Local File Inclusion (nuclei): http/cves/2018/CVE-2018-6184.yaml

## Other vulnerabilities in n/a

- [CVE-2017-16877](https://insights.sbomify.com/CVE-2017-16877/): Next.js Directory Traversal Vulnerability (high 7.5)
- [CVE-2018-18282](https://insights.sbomify.com/CVE-2018-18282/): Next.js has cross site scripting (XSS) vulnerability via the 404 or 500 /_error page (medium 6.1)
- [CVE-2020-5284](https://insights.sbomify.com/CVE-2020-5284/): Directory Traversal in Next.js versions below 9.3.2 (medium 4.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-6184 and fix it if it is affected.

What it is: CVE-2018-6184 is a high-severity path traversal vulnerability in n/a, published on 24 Jan 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2018-6184 exists.

Affected packages and fixed versions:
- next (npm): affected from 1.0.0; fixed in 4.2.3
- next (npm): affected from 1.0.0; fixed in 4.2.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-6184/ (Markdown: https://insights.sbomify.com/CVE-2018-6184/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-6184
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-6184
- OSV: https://osv.dev/vulnerability/CVE-2018-6184

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-6184/
Summaries are generated and may contain mistakes; the official description above is the record.
