CVE-2018-6188 Django vulnerable to information leakage in AuthenticationForm
Remote attackers can discover if user accounts are inactive via Django's authentication form, exposing sensitive account status information.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2018-6188?
CVE-2018-6188 is a high-severity vulnerability in Canonical Ubuntu Linux, published on 5 Feb 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
django.contrib.auth.forms.AuthenticationForm in Django 2.0 before 2.0.2, and 1.11.8 and 1.11.9, allows remote attackers to obtain potentially sensitive information by leveraging data exposure from the confirm_login_allowed() method, as demonstrated by discovering whether a user account is inactive.
Weakness: CWE-200
Which versions are affected by CVE-2018-6188?
5 open source packages ship an affected version, including django and Django. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
django PyPI | From 1.11.8 | 1.11.10 |
django PyPI | From 2.0 | 2.0.2 |
django PyPI | From 2.0a1 | 2.0.2 |
Django PyPI | From 1.11.8 | 1.11.10 |
Django PyPI | From 2.0a1 | 2.0.2 |
Products include Canonical Ubuntu Linux, Djangoproject Django.
How do I fix CVE-2018-6188?
Upgrade django to a fixed version for your release line: 1.11.10 or 2.0.2.
Is CVE-2018-6188 being exploited?
There is no known exploitation of CVE-2018-6188 in the wild and no public exploit code.
Other vulnerabilities in Canonical Ubuntu Linux
Sources
Also known as ALPINE-CVE-2018-6188, DEBIAN-CVE-2018-6188, GHSA-rf4j-j272-fj86, PYSEC-2018-4.