# CVE-2018-6333: Nuclide Improper Input Validation

> Attackers can inject HTML via malicious URLs in Nuclide, potentially leading to code execution within the editor context.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Dec 2018
- **Updated:** 6 May 2025
- **Also known as:** GHSA-r83x-wj75-v89r

## What is CVE-2018-6333?

CVE-2018-6333 is a critical cross-site scripting vulnerability in Facebook Nuclide, published on 31 Dec 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The hhvm-attach deep link handler in Nuclide did not properly sanitize the provided hostname parameter when rendering. As a result, a malicious URL could be used to render HTML and other content inside of the editor's context, which could potentially be chained to lead to code execution. This issue affected Nuclide prior to v0.290.0.

Weakness: CWE-20 (Improper Input Validation), CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2018-6333?

2 open source packages ship an affected version, including nuclide. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nuclide` | npm | All versions | 0.290.0 |
| `nuclide` | npm | All versions | 0.290.0 |

Products: Facebook Nuclide.

## How do I fix CVE-2018-6333?

Upgrade nuclide to 0.290.0 or later.

## Is CVE-2018-6333 being exploited?

There is no known exploitation of CVE-2018-6333 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-6333 and fix it if it is affected.

What it is: CVE-2018-6333 is a critical cross-site scripting vulnerability in Facebook Nuclide, published on 31 Dec 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-6333 in the wild and no public exploit code.

Affected packages and fixed versions:
- nuclide (npm): affected all versions; fixed in 0.290.0
- nuclide (npm): affected all versions; fixed in 0.290.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-6333/ (Markdown: https://insights.sbomify.com/CVE-2018-6333/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-6333
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-6333
- OSV: https://osv.dev/vulnerability/CVE-2018-6333

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-6333/
Summaries are generated and may contain mistakes; the official description above is the record.
