# CVE-2018-6342: react-dev-utils on Windows vulnerable to Remote Code Execution

> An attacker can execute arbitrary commands on a developer's Windows machine by sending unsanitized requests to the local react-dev-utils server.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Dec 2018
- **Updated:** 6 May 2025
- **Also known as:** GHSA-29gp-92wp-94q8

## What is CVE-2018-6342?

CVE-2018-6342 is a critical command injection vulnerability in Facebook react-dev-utils, published on 31 Dec 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

react-dev-utils on Windows allows developers to run a local webserver for accepting various commands, including a command to launch an editor. The input to that command was not properly sanitized, allowing an attacker who can make a network request to the server (either via CSRF or by direct request) to execute arbitrary commands on the targeted system. This issue affects multiple branches: 1.x.x prior to 1.0.4, 2.x.x prior to 2.0.2, 3.x.x prior to 3.1.2, 4.x.x prior to 4.2.2, and 5.x.x prior to 5.0.2.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2018-6342?

10 open source packages ship an affected version, including react-dev-utils. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `react-dev-utils` | npm | From 1.0.0 | 1.0.4 |
| `react-dev-utils` | npm | From 1.0.0 | 1.0.4 |
| `react-dev-utils` | npm | From 2.0.0 | 2.0.2 |
| `react-dev-utils` | npm | From 2.0.0 | 2.0.2 |
| `react-dev-utils` | npm | From 3.0.0 | 3.1.2 |
| `react-dev-utils` | npm | From 3.0.0 | 3.1.2 |
| `react-dev-utils` | npm | From 4.0.0 | 4.2.2 |
| `react-dev-utils` | npm | From 4.0.0 | 4.2.2 |
| `react-dev-utils` | npm | From 5.0.0 | 5.0.2 |
| `react-dev-utils` | npm | From 5.0.0 | 5.0.2 |

Products: Facebook React-Dev-Utils.

## How do I fix CVE-2018-6342?

Upgrade react-dev-utils to a fixed version for your release line: 1.0.4, 2.0.2, 3.1.2 or 4.2.2.

## Is CVE-2018-6342 being exploited?

There is no known exploitation of CVE-2018-6342 in the wild and no public exploit code.

## Other vulnerabilities in Facebook react-dev-utils

- [CVE-2021-24033](https://insights.sbomify.com/CVE-2021-24033/): react-dev-utils OS Command Injection in function `getProcessForPort` (medium 5.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-6342 and fix it if it is affected.

What it is: CVE-2018-6342 is a critical command injection vulnerability in Facebook react-dev-utils, published on 31 Dec 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-6342 in the wild and no public exploit code.

Affected packages and fixed versions:
- react-dev-utils (npm): affected from 1.0.0; fixed in 1.0.4
- react-dev-utils (npm): affected from 1.0.0; fixed in 1.0.4
- react-dev-utils (npm): affected from 2.0.0; fixed in 2.0.2
- react-dev-utils (npm): affected from 2.0.0; fixed in 2.0.2
- react-dev-utils (npm): affected from 3.0.0; fixed in 3.1.2
- react-dev-utils (npm): affected from 3.0.0; fixed in 3.1.2
- react-dev-utils (npm): affected from 4.0.0; fixed in 4.2.2
- react-dev-utils (npm): affected from 4.0.0; fixed in 4.2.2
- react-dev-utils (npm): affected from 5.0.0; fixed in 5.0.2
- react-dev-utils (npm): affected from 5.0.0; fixed in 5.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-6342/ (Markdown: https://insights.sbomify.com/CVE-2018-6342/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-6342
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-6342
- OSV: https://osv.dev/vulnerability/CVE-2018-6342

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-6342/
Summaries are generated and may contain mistakes; the official description above is the record.
