# CVE-2018-6356: Improper Limitation of a Pathname to a Restricted Directory in Jenkins

> Attackers with read permissions can exploit path traversal to download unauthorized files from the Jenkins master server.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Feb 2018
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-5p59-v5wm-77v4

## What is CVE-2018-6356?

CVE-2018-6356 is a medium-severity path traversal vulnerability in Jenkins Jenkins, published on 20 Feb 2018. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Jenkins before 2.107 and Jenkins LTS before 2.89.4 did not properly prevent specifying relative paths that escape a base directory for URLs accessing plugin resource files. This allowed users with Overall/Read permission to download files from the Jenkins master they should not have access to. On Windows, any file accessible to the Jenkins master process could be downloaded. On other operating systems, any file within the Jenkins home directory accessible to the Jenkins master process could be downloaded.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2018-6356?

4 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.main:jenkins-core` | Maven | All versions | 2.89.4 |
| `org.jenkins-ci.main:jenkins-core` | Maven | All versions | 2.89.4 |
| `org.jenkins-ci.main:jenkins-core` | Maven | From 2.90 | 2.107 |
| `org.jenkins-ci.main:jenkins-core` | Maven | From 2.90 | 2.107 |

Products: Jenkins Jenkins, Oracle Communications Cloud Native Core Automated Test Suite.

## How do I fix CVE-2018-6356?

Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 2.89.4 or 2.107.

## Is CVE-2018-6356 being exploited?

There is no known exploitation of CVE-2018-6356 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Jenkins

- [CVE-2024-23897](https://insights.sbomify.com/CVE-2024-23897/): Jenkins Command Line Interface (CLI) Path Traversal (critical 9.8, exploited in the wild)
- [CVE-2018-1000861](https://insights.sbomify.com/CVE-2018-1000861/): Jenkins Stapler Web Framework Deserialization of Untrusted Data (critical 9.8, exploited in the wild)
- [CVE-2017-1000353](https://insights.sbomify.com/CVE-2017-1000353/): Jenkins Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2015-5317](https://insights.sbomify.com/CVE-2015-5317/): Jenkins User Interface (UI) Information Disclosure (high 7.5, exploited in the wild)
- [CVE-2021-21690](https://insights.sbomify.com/CVE-2021-21690/): Multiple vulnerabilities allow bypassing path filtering of agent-to-controller access control in Jenkins (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-6356 and fix it if it is affected.

What it is: CVE-2018-6356 is a medium-severity path traversal vulnerability in Jenkins Jenkins, published on 20 Feb 2018. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-6356 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.main:jenkins-core (Maven): affected all versions; fixed in 2.89.4
- org.jenkins-ci.main:jenkins-core (Maven): affected all versions; fixed in 2.89.4
- org.jenkins-ci.main:jenkins-core (Maven): affected from 2.90; fixed in 2.107
- org.jenkins-ci.main:jenkins-core (Maven): affected from 2.90; fixed in 2.107

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-6356/ (Markdown: https://insights.sbomify.com/CVE-2018-6356/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-6356
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-6356
- OSV: https://osv.dev/vulnerability/CVE-2018-6356

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-6356/
Summaries are generated and may contain mistakes; the official description above is the record.
