{"answers":{"affected":"It affects 2 products.","exploited":"There is no known exploitation of CVE-2018-6360 in the wild and no public exploit code.","fix":"Apply the vendor's patch.","what":"CVE-2018-6360 is a high-severity code injection vulnerability in Debian Debian Linux, published on 28 Jan 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2018-6360 and fix it if it is affected.\n\nWhat it is: CVE-2018-6360 is a high-severity code injection vulnerability in Debian Debian Linux, published on 28 Jan 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2018-6360 in the wild and no public exploit code.\n\nAffected product: Debian Debian Linux. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-6360/ (Markdown: https://insights.sbomify.com/CVE-2018-6360/index.md)","id":"CVE-2018-6360","markdown":"https://insights.sbomify.com/CVE-2018-6360/index.md","name":"CVE-2018-6360","record":{"aliases":["DEBIAN-CVE-2018-6360","DSA-4105-1","GHSA-rj86-j8mq-h692","MGASA-2018-0130","UBUNTU-CVE-2018-6360","openSUSE-SU-2024:11062-1"],"analysis":{"component_type":"desktop_application","fix_type":"patch","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"mpv media player","requires_auth":"none","summary":"Remote attackers can execute arbitrary code via crafted websites due to unsafe URL handling in mpv's youtube-dl hook.","user_interaction":"required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"debian_linux","vendor":"debian"},{"product":"mpv","vendor":"mpv"}],"cvss":{"score":8.8,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"mpv through 0.28.0 allows remote attackers to execute arbitrary code via a crafted web site, because it reads HTML documents containing VIDEO elements, and accepts arbitrary URLs in a src attribute without a protocol whitelist in player/lua/ytdl_hook.lua. For example, an av://lavfi:ladspa=file= URL signifies that the product should call dlopen on a shared object file located at an arbitrary local pathname. The issue exists because the product does not consider that youtube-dl can provide a potentially unsafe URL.","ecosystems":["openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Code injection in n/a","id":"CVE-2018-6360","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"debian:debian_linux","products":["debian:debian_linux"],"type":"code_injection","year":"2018"},"n_packages":1,"n_references":4,"next":{"headline":"Cross-site scripting in n/a","id":"CVE-2018-6361"},"packages":[{"ecosystem":"openSUSE:Tumbleweed","fixed":["0.33.1+git.20210630T163736.f2afae55e9-1.4"],"introduced":["0"],"last_affected":[],"package":"mpv","purl":"pkg:rpm/opensuse/mpv\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:11062-1"}],"prev":{"headline":"Use after free in n/a","id":"CVE-2018-6359"},"products":["n/a"],"published":"2018-01-28","related":[{"cvss_score":10,"headline":"ProFTPD Improper Access Control","id":"CVE-2015-3306","kev_date_added":"2026-10-08","published":"2015-05-18"},{"cvss_score":9.9,"headline":"RoundCube Webmail Deserialization of Untrusted Data","id":"CVE-2025-49113","kev_date_added":"2026-02-20","published":"2025-06-02"},{"cvss_score":9.8,"headline":"GNU InetUtils Argument Injection","id":"CVE-2026-24061","kev_date_added":"2026-01-26","published":"2026-01-21"},{"cvss_score":9.8,"headline":"Linux Kernel Improper Check for Unusual or Exceptional Conditions","id":"CVE-2025-39682","kev_date_added":"2026-09-18","published":"2025-09-05"},{"cvss_score":9.8,"headline":"Mozilla Firefox Use-After-Free","id":"CVE-2024-9680","kev_date_added":"2024-10-15","published":"2024-10-09"},{"cvss_score":9.8,"headline":"RARLAB UnRAR Directory Traversal","id":"CVE-2022-30333","kev_date_added":"2022-08-09","published":"2022-05-09"},{"cvss_score":9.8,"headline":"Roundcube Webmail SQL Injection","id":"CVE-2021-44026","kev_date_added":"2023-06-22","published":"2021-11-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Remote attackers can execute arbitrary code via crafted websites due to unsafe URL handling in mpv's youtube-dl hook.","url":"https://insights.sbomify.com/CVE-2018-6360/"}