# CVE-2018-6517: Improper Certificate Validation in chloride

> Chloride library automatically added unknown host fingerprints to known_hosts, bypassing SSH host verification and enabling potential man-in-the-middle attacks.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Mar 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-573x-jhqh-jg36

## What is CVE-2018-6517?

CVE-2018-6517 is a high-severity vulnerability in Puppet Chloride, published on 17 Mar 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Prior to version 0.3.0, chloride's use of net-ssh resulted in host fingerprints for previously unknown hosts getting added to the user's known_hosts file without confirmation. In version 0.3.0 this is updated so that the user's known_hosts file is not updated by chloride.

Weakness: CWE-295 (Improper Certificate Validation)

## Which versions are affected by CVE-2018-6517?

2 open source packages ship an affected version, including chloride. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `chloride` | RubyGems | All versions | 0.3.0 |
| `chloride` | RubyGems | All versions | 0.3.0 |

Products: Puppet Chloride.

## How do I fix CVE-2018-6517?

Upgrade chloride to 0.3.0 or later.

## Is CVE-2018-6517 being exploited?

There is no known exploitation of CVE-2018-6517 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-6517 and fix it if it is affected.

What it is: CVE-2018-6517 is a high-severity vulnerability in Puppet Chloride, published on 17 Mar 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-6517 in the wild and no public exploit code.

Affected packages and fixed versions:
- chloride (RubyGems): affected all versions; fixed in 0.3.0
- chloride (RubyGems): affected all versions; fixed in 0.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-6517/ (Markdown: https://insights.sbomify.com/CVE-2018-6517/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-6517
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-6517
- OSV: https://osv.dev/vulnerability/CVE-2018-6517

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-6517/
Summaries are generated and may contain mistakes; the official description above is the record.
