CVE-2018-6519 SimpleSAMLphp SAML2 library Regular Expression Denial of Service vulnerability
An attacker can cause a denial of service in SimpleSAMLphp by sending specially crafted timestamp data with fraction-of-seconds.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2018-6519?
CVE-2018-6519 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 2 Feb 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
The SAML2 library before 1.10.4, 2.x before 2.3.5, and 3.x before 3.1.1 in SimpleSAMLphp has a Regular Expression Denial of Service vulnerability for fraction-of-seconds data in a timestamp.
Weakness: CWE-74
Which versions are affected by CVE-2018-6519?
6 open source packages ship an affected version, including simplesamlphp/saml2. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
simplesamlphp/saml2 Packagist | All versions | 1.10.4 |
simplesamlphp/saml2 Packagist | All versions | 1.10.4 |
simplesamlphp/saml2 Packagist | From 2.0 | 2.3.5 |
simplesamlphp/saml2 Packagist | From 2.0 | 2.3.5 |
simplesamlphp/saml2 Packagist | From 3.0 | 3.1.1 |
simplesamlphp/saml2 Packagist | From 3.0 | 3.1.1 |
Products include Debian Debian Linux, Simplesamlphp Saml2.
How do I fix CVE-2018-6519?
Upgrade simplesamlphp/saml2 to a fixed version for your release line: 1.10.4, 2.3.5 or 3.1.1.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2018-6519 being exploited?
There is no known exploitation of CVE-2018-6519 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as DEBIAN-CVE-2018-6519, GHSA-hhm8-2j4g-mpgg, UBUNTU-CVE-2018-6519.