# CVE-2018-6519: SimpleSAMLphp SAML2 library Regular Expression Denial of Service vulnerability

> An attacker can cause a denial of service in SimpleSAMLphp by sending specially crafted timestamp data with fraction-of-seconds.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Feb 2018
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2018-6519, GHSA-hhm8-2j4g-mpgg, UBUNTU-CVE-2018-6519

## What is CVE-2018-6519?

CVE-2018-6519 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 2 Feb 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The SAML2 library before 1.10.4, 2.x before 2.3.5, and 3.x before 3.1.1 in SimpleSAMLphp has a Regular Expression Denial of Service vulnerability for fraction-of-seconds data in a timestamp.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2018-6519?

6 open source packages ship an affected version, including simplesamlphp/saml2. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `simplesamlphp/saml2` | Packagist | All versions | 1.10.4 |
| `simplesamlphp/saml2` | Packagist | All versions | 1.10.4 |
| `simplesamlphp/saml2` | Packagist | From 2.0 | 2.3.5 |
| `simplesamlphp/saml2` | Packagist | From 2.0 | 2.3.5 |
| `simplesamlphp/saml2` | Packagist | From 3.0 | 3.1.1 |
| `simplesamlphp/saml2` | Packagist | From 3.0 | 3.1.1 |

Products: Debian Debian Linux, Simplesamlphp Saml2.

## How do I fix CVE-2018-6519?

Upgrade simplesamlphp/saml2 to a fixed version for your release line: 1.10.4, 2.3.5 or 3.1.1.

## Is CVE-2018-6519 being exploited?

There is no known exploitation of CVE-2018-6519 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-6519 and fix it if it is affected.

What it is: CVE-2018-6519 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 2 Feb 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-6519 in the wild and no public exploit code.

Affected packages and fixed versions:
- simplesamlphp/saml2 (Packagist): affected all versions; fixed in 1.10.4
- simplesamlphp/saml2 (Packagist): affected all versions; fixed in 1.10.4
- simplesamlphp/saml2 (Packagist): affected from 2.0; fixed in 2.3.5
- simplesamlphp/saml2 (Packagist): affected from 2.0; fixed in 2.3.5
- simplesamlphp/saml2 (Packagist): affected from 3.0; fixed in 3.1.1
- simplesamlphp/saml2 (Packagist): affected from 3.0; fixed in 3.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-6519/ (Markdown: https://insights.sbomify.com/CVE-2018-6519/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-6519
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-6519
- OSV: https://osv.dev/vulnerability/CVE-2018-6519

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-6519/
Summaries are generated and may contain mistakes; the official description above is the record.
