{"answers":{"affected":"2 open source packages ship an affected version, including simplesamlphp/simplesamlphp. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-6520 in the wild and no public exploit code.","fix":"Upgrade simplesamlphp/simplesamlphp to 1.15.2 or later.","what":"CVE-2018-6520 is a medium-severity vulnerability in n/a, published on 2 Feb 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2018-6520 and fix it if it is affected.\n\nWhat it is: CVE-2018-6520 is a medium-severity vulnerability in n/a, published on 2 Feb 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2018-6520 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- simplesamlphp/simplesamlphp (Packagist): affected all versions; fixed in 1.15.2\n- simplesamlphp/simplesamlphp (Packagist): affected all versions; fixed in 1.15.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-6520/ (Markdown: https://insights.sbomify.com/CVE-2018-6520/index.md)","id":"CVE-2018-6520","markdown":"https://insights.sbomify.com/CVE-2018-6520/index.md","name":"CVE-2018-6520","record":{"aliases":["DEBIAN-CVE-2018-6520","GHSA-2qfc-48v5-4w5h","UBUNTU-CVE-2018-6520"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"SimpleSAMLphp","requires_auth":"none","summary":"Remote attackers can bypass open redirect protections in SimpleSAMLphp by crafting malicious authority data in URLs.","user_interaction":"required","vuln_class":"open_redirect"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"simplesamlphp","vendor":"simplesamlphp"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-601","name":"URL Redirection to Untrusted Site"}],"description":"SimpleSAMLphp before 1.15.2 allows remote attackers to bypass an open redirect protection mechanism via crafted authority data in a URL.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"SimpleSAMLphp Open redirection protection bypass","id":"CVE-2018-6520","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"open_redirect","year":"2018"},"n_packages":2,"n_references":1,"next":{"headline":"SimpleSAMLphp Use of insecure connection charset (sqlauth module)","id":"CVE-2018-6521"},"packages":[{"ecosystem":"Packagist","fixed":["1.15.2"],"introduced":["0"],"last_affected":[],"package":"simplesamlphp/simplesamlphp","purl":null,"source":"GHSA-2qfc-48v5-4w5h"},{"ecosystem":"Packagist","fixed":["1.15.2"],"introduced":["0"],"last_affected":[],"package":"simplesamlphp/simplesamlphp","purl":"pkg:composer/simplesamlphp/simplesamlphp","source":"GHSA-2qfc-48v5-4w5h"}],"prev":{"headline":"SimpleSAMLphp SAML2 library Regular Expression Denial of Service vulnerability","id":"CVE-2018-6519"},"products":["n/a"],"published":"2018-02-02","related":[{"cvss_score":9.8,"headline":"SimpleSAMLphp Session fixation issue and authentication bypass in the authcrypt module","id":"CVE-2017-12868","kev_date_added":null,"published":"2017-09-01"},{"cvss_score":7.5,"headline":"SimpleSAMLphp Improper Verification of Cryptographic Signature","id":"CVE-2018-7644","kev_date_added":null,"published":"2018-03-05"},{"cvss_score":7.1,"headline":"SimpleSAMLphp SP accepts a response from an unexpected IdP when unsigned `Response/InResponseTo` is combined with a signed assertion lacking `SubjectConfirmationData/InResponseTo`","id":"CVE-2026-49284","kev_date_added":null,"published":"2026-07-17"},{"cvss_score":5.9,"headline":"SimpleSAMLphp Unauthenticated encryption in CBC mode","id":"CVE-2017-12870","kev_date_added":null,"published":"2017-09-01"},{"cvss_score":5.9,"headline":"SimpleSAMLphp Incorrect IV generation for encryption","id":"CVE-2017-12871","kev_date_added":null,"published":"2017-09-01"},{"cvss_score":5.9,"headline":"SimpleSAMLphp Invalid token creation and validation","id":"CVE-2017-12867","kev_date_added":null,"published":"2017-08-29"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Remote attackers can bypass open redirect protections in SimpleSAMLphp by crafting malicious authority data in URLs.","url":"https://insights.sbomify.com/CVE-2018-6520/"}