# CVE-2018-6520: SimpleSAMLphp Open redirection protection bypass

> Remote attackers can bypass open redirect protections in SimpleSAMLphp by crafting malicious authority data in URLs.

- **Severity:** Medium 6.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 2 Feb 2018
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2018-6520, GHSA-2qfc-48v5-4w5h, UBUNTU-CVE-2018-6520

## What is CVE-2018-6520?

CVE-2018-6520 is a medium-severity vulnerability in n/a, published on 2 Feb 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

SimpleSAMLphp before 1.15.2 allows remote attackers to bypass an open redirect protection mechanism via crafted authority data in a URL.

Weakness: CWE-601 (URL Redirection to Untrusted Site)

## Which versions are affected by CVE-2018-6520?

2 open source packages ship an affected version, including simplesamlphp/simplesamlphp. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `simplesamlphp/simplesamlphp` | Packagist | All versions | 1.15.2 |
| `simplesamlphp/simplesamlphp` | Packagist | All versions | 1.15.2 |

Products: Simplesamlphp Simplesamlphp.

## How do I fix CVE-2018-6520?

Upgrade simplesamlphp/simplesamlphp to 1.15.2 or later.

## Is CVE-2018-6520 being exploited?

There is no known exploitation of CVE-2018-6520 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2017-12868](https://insights.sbomify.com/CVE-2017-12868/): SimpleSAMLphp Session fixation issue and authentication bypass in the authcrypt module (critical 9.8)
- [CVE-2018-7644](https://insights.sbomify.com/CVE-2018-7644/): SimpleSAMLphp Improper Verification of Cryptographic Signature (high 7.5)
- [CVE-2026-49284](https://insights.sbomify.com/CVE-2026-49284/): SimpleSAMLphp SP accepts a response from an unexpected IdP when unsigned `Response/InResponseTo` is combined with a signed assertion lacking `SubjectConfirmationData/InResponseTo` (high 7.1)
- [CVE-2017-12870](https://insights.sbomify.com/CVE-2017-12870/): SimpleSAMLphp Unauthenticated encryption in CBC mode (medium 5.9)
- [CVE-2017-12871](https://insights.sbomify.com/CVE-2017-12871/): SimpleSAMLphp Incorrect IV generation for encryption (medium 5.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-6520 and fix it if it is affected.

What it is: CVE-2018-6520 is a medium-severity vulnerability in n/a, published on 2 Feb 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2018-6520 in the wild and no public exploit code.

Affected packages and fixed versions:
- simplesamlphp/simplesamlphp (Packagist): affected all versions; fixed in 1.15.2
- simplesamlphp/simplesamlphp (Packagist): affected all versions; fixed in 1.15.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-6520/ (Markdown: https://insights.sbomify.com/CVE-2018-6520/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-6520
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-6520
- OSV: https://osv.dev/vulnerability/CVE-2018-6520

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-6520/
Summaries are generated and may contain mistakes; the official description above is the record.
