{"answers":{"affected":"3 open source packages ship an affected version, including github.com/google/fscrypt. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-6558 in the wild and no public exploit code.","fix":"Upgrade github.com/google/fscrypt to 0.2.4 or later.","what":"CVE-2018-6558 is a medium-severity vulnerability in The fscrypt Project fscrypt, published on 23 Aug 2018. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-6558 and fix it if it is affected.\n\nWhat it is: CVE-2018-6558 is a medium-severity vulnerability in The fscrypt Project fscrypt, published on 23 Aug 2018. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-6558 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/google/fscrypt (Go): affected all versions; fixed in 0.2.4\n- github.com/google/fscrypt (Go): affected all versions; fixed in 0.2.4\n- github.com/google/fscrypt (Go): affected all versions; fixed in 0.2.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-6558/ (Markdown: https://insights.sbomify.com/CVE-2018-6558/index.md)","id":"CVE-2018-6558","markdown":"https://insights.sbomify.com/CVE-2018-6558/index.md","name":"CVE-2018-6558","record":{"aliases":["DEBIAN-CVE-2018-6558","GHSA-qj26-7grj-whg3","GO-2020-0027","UBUNTU-CVE-2018-6558"],"analysis":{"component_type":"operating_system","fix_type":"upgrade","impacts":["privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"Linux PAM module","requires_auth":"low_privilege","summary":"Attackers can gain root privileges via successful login due to incorrect group ID restoration in the fscrypt PAM module.","user_interaction":"not_required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"canonical","cpe":[{"product":"fscrypt","vendor":"google"}],"cvss":{"score":6.5,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N","version":"3.0"},"cwes":[],"description":"The pam_fscrypt module in fscrypt before 0.2.4 may incorrectly restore primary and supplementary group IDs to the values associated with the root user, which allows attackers to gain privileges via a successful login through certain applications that use Linux-PAM (aka pam).","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Privilege Escalation in fscrypt","id":"CVE-2018-6558","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"privilege_escalation","year":"2018"},"n_packages":3,"n_references":4,"next":{"headline":"Information disclosure in Linux kernel, as used in Ubuntu 18.04 LTS and Ubuntu 18.10","id":"CVE-2018-6559"},"packages":[{"ecosystem":"Go","fixed":["0.2.4"],"introduced":["0"],"last_affected":[],"package":"github.com/google/fscrypt","purl":null,"source":"GHSA-qj26-7grj-whg3"},{"ecosystem":"Go","fixed":["0.2.4"],"introduced":["0"],"last_affected":[],"package":"github.com/google/fscrypt","purl":"pkg:golang/github.com/google/fscrypt","source":"GHSA-qj26-7grj-whg3"},{"ecosystem":"Go","fixed":["0.2.4"],"introduced":["0"],"last_affected":[],"package":"github.com/google/fscrypt","purl":"pkg:golang/github.com/google/fscrypt","source":"GO-2020-0027"}],"prev":{"headline":"Insecure temporary file use in base-files","id":"CVE-2018-6557"},"products":["fscrypt"],"published":"2018-08-23","related":[{"cvss_score":5.5,"headline":"Denial of Service in fscrypt","id":"CVE-2022-25326","kev_date_added":null,"published":"2022-02-25"},{"cvss_score":5.5,"headline":"Local Denial of Service in fscrypt PAM module","id":"CVE-2022-25327","kev_date_added":null,"published":"2022-02-25"},{"cvss_score":5,"headline":"Privilege escalation through command injection in fscrypt","id":"CVE-2022-25328","kev_date_added":null,"published":"2022-02-25"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-17","vendors":["The fscrypt Project"]},"summary":"Attackers can gain root privileges via successful login due to incorrect group ID restoration in the fscrypt PAM module.","url":"https://insights.sbomify.com/CVE-2018-6558/"}