# CVE-2018-6558: Privilege Escalation in fscrypt

> Attackers can gain root privileges via successful login due to incorrect group ID restoration in the fscrypt PAM module.

- **Severity:** Medium 6.5 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Aug 2018
- **Updated:** 17 Sep 2024
- **Also known as:** DEBIAN-CVE-2018-6558, GHSA-qj26-7grj-whg3, GO-2020-0027, UBUNTU-CVE-2018-6558

## What is CVE-2018-6558?

CVE-2018-6558 is a medium-severity vulnerability in The fscrypt Project fscrypt, published on 23 Aug 2018. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The pam_fscrypt module in fscrypt before 0.2.4 may incorrectly restore primary and supplementary group IDs to the values associated with the root user, which allows attackers to gain privileges via a successful login through certain applications that use Linux-PAM (aka pam).

## Which versions are affected by CVE-2018-6558?

3 open source packages ship an affected version, including github.com/google/fscrypt. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/google/fscrypt` | Go | All versions | 0.2.4 |
| `github.com/google/fscrypt` | Go | All versions | 0.2.4 |
| `github.com/google/fscrypt` | Go | All versions | 0.2.4 |

Products: Google Fscrypt.

## How do I fix CVE-2018-6558?

Upgrade github.com/google/fscrypt to 0.2.4 or later.

## Is CVE-2018-6558 being exploited?

There is no known exploitation of CVE-2018-6558 in the wild and no public exploit code.

## Other vulnerabilities in The fscrypt Project fscrypt

- [CVE-2022-25326](https://insights.sbomify.com/CVE-2022-25326/): Denial of Service in fscrypt (medium 5.5)
- [CVE-2022-25327](https://insights.sbomify.com/CVE-2022-25327/): Local Denial of Service in fscrypt PAM module (medium 5.5)
- [CVE-2022-25328](https://insights.sbomify.com/CVE-2022-25328/): Privilege escalation through command injection in fscrypt (medium 5.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-6558 and fix it if it is affected.

What it is: CVE-2018-6558 is a medium-severity vulnerability in The fscrypt Project fscrypt, published on 23 Aug 2018. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-6558 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/google/fscrypt (Go): affected all versions; fixed in 0.2.4
- github.com/google/fscrypt (Go): affected all versions; fixed in 0.2.4
- github.com/google/fscrypt (Go): affected all versions; fixed in 0.2.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-6558/ (Markdown: https://insights.sbomify.com/CVE-2018-6558/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-6558
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-6558
- OSV: https://osv.dev/vulnerability/CVE-2018-6558

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-6558/
Summaries are generated and may contain mistakes; the official description above is the record.
