# CVE-2018-6561: dijit editor cross-site scripting vulnerability

> Cross-site scripting vulnerability in Dojo Toolkit allows attackers to execute arbitrary scripts via SVG onload attributes.

- **Severity:** Medium 6.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 2 Feb 2018
- **Updated:** 16 Sep 2024
- **Also known as:** DEBIAN-CVE-2018-6561, GHSA-wp32-wq34-2rqh, UBUNTU-CVE-2018-6561

## What is CVE-2018-6561?

CVE-2018-6561 is a medium-severity cross-site scripting vulnerability in n/a, published on 2 Feb 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

dijit.Editor in Dojo Toolkit 1.13 allows XSS via the onload attribute of an SVG element.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2018-6561?

2 open source packages ship an affected version, including dijit. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `dijit` | npm | All versions | 1.13.1 |
| `dijit` | npm | All versions | 1.13.1 |

Products: Dojotoolkit Dojo.

## How do I fix CVE-2018-6561?

Upgrade dijit to 1.13.1 or later.

## Is CVE-2018-6561 being exploited?

There is no known exploitation of CVE-2018-6561 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2010-2272](https://insights.sbomify.com/CVE-2010-2272/): Other in n/a (critical 10.0)
- [CVE-2010-2276](https://insights.sbomify.com/CVE-2010-2276/): Misconfiguration in n/a (critical 10.0)
- [CVE-2018-1000665](https://insights.sbomify.com/CVE-2018-1000665/): Improper Neutralization of Input During Web Page Generation in Dojo Dojo Objective Harness (medium 6.1)
- [CVE-2015-5654](https://insights.sbomify.com/CVE-2015-5654/): Cross-Site Scripting in dojo (medium 4.3)
- [CVE-2010-2273](https://insights.sbomify.com/CVE-2010-2273/): Cross-Site Scripting in dojo (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-6561 and fix it if it is affected.

What it is: CVE-2018-6561 is a medium-severity cross-site scripting vulnerability in n/a, published on 2 Feb 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2018-6561 in the wild and no public exploit code.

Affected packages and fixed versions:
- dijit (npm): affected all versions; fixed in 1.13.1
- dijit (npm): affected all versions; fixed in 1.13.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-6561/ (Markdown: https://insights.sbomify.com/CVE-2018-6561/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-6561
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-6561
- OSV: https://osv.dev/vulnerability/CVE-2018-6561

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-6561/
Summaries are generated and may contain mistakes; the official description above is the record.
