CVE-2018-6574 Code injection in n/a
Attackers can execute arbitrary code during Go source builds by exploiting unblocked compiler plugin arguments in the go get command.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Local or same network only
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2018-6574?
CVE-2018-6574 is a high-severity code injection vulnerability in Debian Debian Linux, published on 7 Feb 2018. It can only be exploited from the same machine or local network, with no action from the victim.
Official description
Go before 1.8.7, Go 1.9.x before 1.9.4, and Go 1.10 pre-releases before Go 1.10rc2 allow "go get" remote command execution during source code build, by leveraging the gcc or clang plugin feature, because -fplugin= and -plugin= arguments were not blocked.
Weakness: CWE-94
Which versions are affected by CVE-2018-6574?
1 open source package ship an affected version, including toolchain. It affects 6 products.
| Package | Affected | Fixed in |
|---|---|---|
toolchain Go | All versions | 1.8.7, 1.9.4 |
Linux distribution packages (17)
go-toolset-7 Red Hat:devtools:2018 | All versions | 0:1.8-14.el7 |
go-toolset-7-build Red Hat:devtools:2018 | All versions | 0:1.8-14.el7 |
go-toolset-7-golang Red Hat:devtools:2018 | All versions | 0:1.8.7-2.el7 |
go-toolset-7-golang-bin Red Hat:devtools:2018 | All versions | 0:1.8.7-2.el7 |
go-toolset-7-golang-docs Red Hat:devtools:2018 | All versions | 0:1.8.7-2.el7 |
go-toolset-7-golang-misc Red Hat:devtools:2018 | All versions | 0:1.8.7-2.el7 |
go-toolset-7-golang-race Red Hat:devtools:2018 | All versions | 0:1.8.7-2.el7 |
go-toolset-7-golang-src Red Hat:devtools:2018 | All versions | 0:1.8.7-2.el7 |
go-toolset-7-golang-tests Red Hat:devtools:2018 | All versions | 0:1.8.7-2.el7 |
go-toolset-7-runtime Red Hat:devtools:2018 | All versions | 0:1.8-14.el7 |
go-toolset-7-scldevel Red Hat:devtools:2018 | All versions | 0:1.8-14.el7 |
go SUSE:Package Hub 12 | All versions | 1.9.4-15.1 |
go SUSE:Package Hub 12 | All versions | 1.9.4-15.1 |
go1.8 SUSE:Package Hub 12 | All versions | 1.8.7-5.1 |
go1.8 SUSE:Package Hub 12 | All versions | 1.8.7-5.1 |
go1.9 SUSE:Package Hub 12 | All versions | 1.9.4-5.1 |
go1.9 SUSE:Package Hub 12 | All versions | 1.9.4-5.1 |
Products include Debian Debian Linux, Golang Go, Redhat Enterprise Linux Server, Redhat Enterprise Linux Server Aus, Redhat Enterprise Linux Server Eus, Redhat Enterprise Linux Server Tus.
How do I fix CVE-2018-6574?
Upgrade toolchain to a fixed version for your release line: 1.8.7 or 1.9.4.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2018-6574 being exploited?
There is no known exploitation of CVE-2018-6574 in the wild and no public exploit code.
Public exploit code: 91 proofs of concept on GitHub.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as GHSA-c37c-qq99-c897, GO-2022-0201, MGASA-2018-0144, RHSA-2018:1304, UBUNTU-CVE-2018-6574, openSUSE-SU-2018:0588-1 and 3 more.