{"answers":{"affected":"4 open source packages ship an affected version, including jcbrand/converse.js and converse.js. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-6591 in the wild and no public exploit code.","fix":"Upgrade jcbrand/converse.js to 3.3.3 or later.","what":"CVE-2018-6591 is a medium-severity vulnerability in n/a, published on 19 Feb 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-6591 and fix it if it is affected.\n\nWhat it is: CVE-2018-6591 is a medium-severity vulnerability in n/a, published on 19 Feb 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-6591 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- jcbrand/converse.js (Packagist): affected all versions; fixed in 3.3.3\n- jcbrand/converse.js (Packagist): affected all versions; fixed in 3.3.3\n- converse.js (npm): affected all versions; fixed in 3.3.3\n- converse.js (npm): affected all versions; fixed in 3.3.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-6591/ (Markdown: https://insights.sbomify.com/CVE-2018-6591/index.md)","id":"CVE-2018-6591","markdown":"https://insights.sbomify.com/CVE-2018-6591/index.md","name":"CVE-2018-6591","record":{"aliases":["GHSA-mv4h-qm24-x4gh"],"analysis":{"component_type":"web_application","fix_type":"patch","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Chat client library","requires_auth":"none","summary":"Remote attackers can access private chatroom bookmarks due to ambiguous configuration of safe publication settings in Converse.js and Inverse.js.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"converse.js","vendor":"conversejs"}],"cvss":{"score":5.3,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N","version":"3.0"},"cwes":[{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"Converse.js and Inverse.js through 3.3 allow remote attackers to obtain sensitive information because it is too difficult to determine whether safe publication of private data was configured or even intended. For example, users might have an expectation that chatroom bookmarks are private, but the various interacting software components do not necessarily make that happen.","ecosystems":["Packagist","npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Converse.js Exposure of Sensitive Information","id":"CVE-2018-6591","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"information_disclosure","year":"2018"},"n_packages":4,"n_references":1,"next":{"headline":"Information disclosure in n/a","id":"CVE-2018-6592"},"packages":[{"ecosystem":"Packagist","fixed":["3.3.3"],"introduced":["0"],"last_affected":[],"package":"jcbrand/converse.js","purl":null,"source":"GHSA-mv4h-qm24-x4gh"},{"ecosystem":"Packagist","fixed":["3.3.3"],"introduced":["0"],"last_affected":[],"package":"jcbrand/converse.js","purl":"pkg:composer/jcbrand/converse.js","source":"GHSA-mv4h-qm24-x4gh"},{"ecosystem":"npm","fixed":["3.3.3"],"introduced":["0"],"last_affected":[],"package":"converse.js","purl":null,"source":"GHSA-mv4h-qm24-x4gh"},{"ecosystem":"npm","fixed":["3.3.3"],"introduced":["0"],"last_affected":[],"package":"converse.js","purl":"pkg:npm/converse.js","source":"GHSA-mv4h-qm24-x4gh"}],"prev":{"headline":"Cross-site scripting in CA API Developer Portal","id":"CVE-2018-6590"},"products":["n/a"],"published":"2018-02-19","related":[{"cvss_score":5.9,"headline":"User Impersonation in converse.js","id":"CVE-2017-5858","kev_date_added":null,"published":"2017-02-09"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Remote attackers can access private chatroom bookmarks due to ambiguous configuration of safe publication settings in Converse.js and Inverse.js.","url":"https://insights.sbomify.com/CVE-2018-6591/"}