# CVE-2018-6591: Converse.js Exposure of Sensitive Information

> Remote attackers can access private chatroom bookmarks due to ambiguous configuration of safe publication settings in Converse.js and Inverse.js.

- **Severity:** Medium 5.3 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Feb 2018
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-mv4h-qm24-x4gh

## What is CVE-2018-6591?

CVE-2018-6591 is a medium-severity vulnerability in n/a, published on 19 Feb 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Converse.js and Inverse.js through 3.3 allow remote attackers to obtain sensitive information because it is too difficult to determine whether safe publication of private data was configured or even intended. For example, users might have an expectation that chatroom bookmarks are private, but the various interacting software components do not necessarily make that happen.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2018-6591?

4 open source packages ship an affected version, including jcbrand/converse.js and converse.js. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `jcbrand/converse.js` | Packagist | All versions | 3.3.3 |
| `jcbrand/converse.js` | Packagist | All versions | 3.3.3 |
| `converse.js` | npm | All versions | 3.3.3 |
| `converse.js` | npm | All versions | 3.3.3 |

Products: Conversejs Converse.js.

## How do I fix CVE-2018-6591?

Upgrade jcbrand/converse.js to 3.3.3 or later.

## Is CVE-2018-6591 being exploited?

There is no known exploitation of CVE-2018-6591 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2017-5858](https://insights.sbomify.com/CVE-2017-5858/): User Impersonation in converse.js (medium 5.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-6591 and fix it if it is affected.

What it is: CVE-2018-6591 is a medium-severity vulnerability in n/a, published on 19 Feb 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-6591 in the wild and no public exploit code.

Affected packages and fixed versions:
- jcbrand/converse.js (Packagist): affected all versions; fixed in 3.3.3
- jcbrand/converse.js (Packagist): affected all versions; fixed in 3.3.3
- converse.js (npm): affected all versions; fixed in 3.3.3
- converse.js (npm): affected all versions; fixed in 3.3.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-6591/ (Markdown: https://insights.sbomify.com/CVE-2018-6591/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-6591
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-6591
- OSV: https://osv.dev/vulnerability/CVE-2018-6591

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-6591/
Summaries are generated and may contain mistakes; the official description above is the record.
