{"answers":{"affected":"2 open source packages ship an affected version, including ep_etherpad-lite. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-6835 in the wild and no public exploit code.","fix":"Upgrade ep_etherpad-lite to 1.6.3 or later.","what":"CVE-2018-6835 is a critical vulnerability in n/a, published on 8 Feb 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-6835 and fix it if it is affected.\n\nWhat it is: CVE-2018-6835 is a critical vulnerability in n/a, published on 8 Feb 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-6835 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ep_etherpad-lite (npm): affected all versions; fixed in 1.6.3\n- ep_etherpad-lite (npm): affected all versions; fixed in 1.6.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-6835/ (Markdown: https://insights.sbomify.com/CVE-2018-6835/index.md)","id":"CVE-2018-6835","markdown":"https://insights.sbomify.com/CVE-2018-6835/index.md","name":"CVE-2018-6835","record":{"aliases":["GHSA-mvmv-rq2j-97p2"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Etherpad Lite","requires_auth":"none","summary":"Remote attackers can bypass intended access restrictions in Etherpad Lite due to improper handling of JSONP requests.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"etherpad","vendor":"etherpad"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"node/hooks/express/apicalls.js in Etherpad Lite before v1.6.3 mishandles JSONP, which allows remote attackers to bypass intended access restrictions.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Etherpad Lite Access Restriction Bypass","id":"CVE-2018-6835","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"security_feature_bypass","year":"2018"},"n_packages":2,"n_references":2,"next":{"headline":"Use after free in n/a","id":"CVE-2018-6836"},"packages":[{"ecosystem":"npm","fixed":["1.6.3"],"introduced":["0"],"last_affected":[],"package":"ep_etherpad-lite","purl":null,"source":"GHSA-mvmv-rq2j-97p2"},{"ecosystem":"npm","fixed":["1.6.3"],"introduced":["0"],"last_affected":[],"package":"ep_etherpad-lite","purl":"pkg:npm/ep_etherpad-lite","source":"GHSA-mvmv-rq2j-97p2"}],"prev":{"headline":"Cross-site scripting in n/a","id":"CVE-2018-6834"},"products":["n/a"],"published":"2018-02-08","related":[{"cvss_score":9.9,"headline":"Admin privilege escalation and arbitrary code execution via malicious *.etherpad imports","id":"CVE-2021-43802","kev_date_added":null,"published":"2021-12-09"},{"cvss_score":9.8,"headline":"Code injection in n/a","id":"CVE-2018-9326","kev_date_added":null,"published":"2018-04-07"},{"cvss_score":8.1,"headline":"Code injection in n/a","id":"CVE-2018-9327","kev_date_added":null,"published":"2018-04-07"},{"cvss_score":7.5,"headline":"Denial of service in n/a","id":"CVE-2020-22781","kev_date_added":null,"published":"2021-04-28"},{"cvss_score":7.5,"headline":"Denial of service in n/a","id":"CVE-2020-22782","kev_date_added":null,"published":"2021-04-28"},{"cvss_score":7.5,"headline":"Denial of service in n/a","id":"CVE-2020-22785","kev_date_added":null,"published":"2021-04-28"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Remote attackers can bypass intended access restrictions in Etherpad Lite due to improper handling of JSONP requests.","url":"https://insights.sbomify.com/CVE-2018-6835/"}