# CVE-2018-6835: Etherpad Lite Access Restriction Bypass

> Remote attackers can bypass intended access restrictions in Etherpad Lite due to improper handling of JSONP requests.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Feb 2018
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-mvmv-rq2j-97p2

## What is CVE-2018-6835?

CVE-2018-6835 is a critical vulnerability in n/a, published on 8 Feb 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

node/hooks/express/apicalls.js in Etherpad Lite before v1.6.3 mishandles JSONP, which allows remote attackers to bypass intended access restrictions.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2018-6835?

2 open source packages ship an affected version, including ep_etherpad-lite. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ep_etherpad-lite` | npm | All versions | 1.6.3 |
| `ep_etherpad-lite` | npm | All versions | 1.6.3 |

Products: Etherpad Etherpad.

## How do I fix CVE-2018-6835?

Upgrade ep_etherpad-lite to 1.6.3 or later.

## Is CVE-2018-6835 being exploited?

There is no known exploitation of CVE-2018-6835 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2021-43802](https://insights.sbomify.com/CVE-2021-43802/): Admin privilege escalation and arbitrary code execution via malicious *.etherpad imports (critical 9.9)
- [CVE-2018-9326](https://insights.sbomify.com/CVE-2018-9326/): Code injection in n/a (critical 9.8)
- [CVE-2018-9327](https://insights.sbomify.com/CVE-2018-9327/): Code injection in n/a (high 8.1)
- [CVE-2020-22781](https://insights.sbomify.com/CVE-2020-22781/): Denial of service in n/a (high 7.5)
- [CVE-2020-22782](https://insights.sbomify.com/CVE-2020-22782/): Denial of service in n/a (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-6835 and fix it if it is affected.

What it is: CVE-2018-6835 is a critical vulnerability in n/a, published on 8 Feb 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-6835 in the wild and no public exploit code.

Affected packages and fixed versions:
- ep_etherpad-lite (npm): affected all versions; fixed in 1.6.3
- ep_etherpad-lite (npm): affected all versions; fixed in 1.6.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-6835/ (Markdown: https://insights.sbomify.com/CVE-2018-6835/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-6835
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-6835
- OSV: https://osv.dev/vulnerability/CVE-2018-6835

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-6835/
Summaries are generated and may contain mistakes; the official description above is the record.
