{"answers":{"affected":"2 open source packages ship an affected version, including auth0-js. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-6874 in the wild and no public exploit code.","fix":"Upgrade auth0-js to 9.0.0 or later.","what":"CVE-2018-6874 is a high-severity vulnerability in n/a, published on 4 Apr 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2018-6874 and fix it if it is affected.\n\nWhat it is: CVE-2018-6874 is a high-severity vulnerability in n/a, published on 4 Apr 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2018-6874 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- auth0-js (npm): affected all versions; fixed in 9.0.0\n- auth0-js (npm): affected all versions; fixed in 9.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-6874/ (Markdown: https://insights.sbomify.com/CVE-2018-6874/index.md)","id":"CVE-2018-6874","markdown":"https://insights.sbomify.com/CVE-2018-6874/index.md","name":"CVE-2018-6874","record":{"aliases":["GHSA-wv26-rj8c-4r33"],"analysis":{"component_type":"cloud_service","fix_type":"configuration_change","impacts":["account_takeover"],"network_reachable":"yes","non_default_config":true,"product_category":"Auth0 authentication service","requires_auth":"none","summary":"Attackers can perform unauthorized actions on behalf of users if the Legacy Lock API flag is enabled in Auth0.","user_interaction":"required","vuln_class":"csrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"auth0.js","vendor":"auth0"}],"cvss":{"score":8.8,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-352","name":"Cross-Site Request Forgery"}],"description":"CSRF exists in the Auth0 authentication service through 14591 if the Legacy Lock API flag is enabled.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cross-Site Request Forgery (CSRF) in Auth0","id":"CVE-2018-6874","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"csrf","year":"2018"},"n_packages":2,"n_references":2,"next":{"headline":"Information disclosure in n/a","id":"CVE-2018-6875"},"packages":[{"ecosystem":"npm","fixed":["9.0.0"],"introduced":["0"],"last_affected":[],"package":"auth0-js","purl":null,"source":"GHSA-wv26-rj8c-4r33"},{"ecosystem":"npm","fixed":["9.0.0"],"introduced":["0"],"last_affected":[],"package":"auth0-js","purl":"pkg:npm/auth0-js","source":"GHSA-wv26-rj8c-4r33"}],"prev":{"headline":"Auth bypass in n/a","id":"CVE-2018-6873"},"products":["n/a"],"published":"2018-04-04","related":[{"cvss_score":9.8,"headline":"Auth bypass in n/a","id":"CVE-2018-6873","kev_date_added":null,"published":"2018-04-04"},{"cvss_score":8.8,"headline":"Auth0-js bypasses CSRF checks","id":"CVE-2018-7307","kev_date_added":null,"published":"2018-03-06"},{"cvss_score":7.7,"headline":"Authorization header is not sanitized in an error object in auth0","id":"CVE-2020-15125","kev_date_added":null,"published":"2020-07-29"},{"cvss_score":7.5,"headline":"auth0-js Privilege Escalation Vulnerability","id":"CVE-2017-17068","kev_date_added":null,"published":"2017-12-06"},{"cvss_score":7.1,"headline":"Improper Permission Checking in Auth.js SDK","id":"CVE-2026-42280","kev_date_added":null,"published":"2026-05-27"},{"cvss_score":5.5,"headline":"Information disclosure through error object","id":"CVE-2020-5263","kev_date_added":null,"published":"2020-04-09"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Attackers can perform unauthorized actions on behalf of users if the Legacy Lock API flag is enabled in Auth0.","url":"https://insights.sbomify.com/CVE-2018-6874/"}