# CVE-2018-6905: Typo3 XSS Vulnerability

> An attacker with admin privileges can inject malicious scripts via the site name configuration, leading to cross-site scripting attacks.

- **Severity:** Medium 4.8 (`CVSS:3.0/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 8 Apr 2018
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-3w22-wrwx-2r75

## What is CVE-2018-6905?

CVE-2018-6905 is a medium-severity cross-site scripting vulnerability in Typo3 Typo3, published on 8 Apr 2018. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

The page module in TYPO3 before 8.7.11, and 9.1.0, has XSS via $GLOBALS['TYPO3_CONF_VARS']['SYS']['sitename'], as demonstrated by an admin entering a crafted site name during the installation process.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2018-6905?

2 open source packages ship an affected version, including typo3/cms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `typo3/cms` | Packagist | All versions | 9.2.0 |
| `typo3/cms` | Packagist | All versions | 9.2.0 |

Products: Typo3 Typo3.

## How do I fix CVE-2018-6905?

Upgrade typo3/cms to 9.2.0 or later.

## Is CVE-2018-6905 being exploited?

There is no known exploitation of CVE-2018-6905 in the wild and no public exploit code.

Public exploit code:

- Typo3 -v9.1.0 Persistent Cross Site Scripting(XSS) Assigned CVE Number: CVE-2018-6905 (github_poc): https://github.com/pradeepjairamani/TYPO3-XSS-POC
- typo3 install.php XSS (github_poc): https://github.com/dnr6419/CVE-2018-6905

## Other vulnerabilities in Typo3 Typo3

- [CVE-2009-0258](https://insights.sbomify.com/CVE-2009-0258/): Indexed Search Engine for TYPO3 Command Execution via Metacharacter Injection (critical 10.0)
- [CVE-2011-3583](https://insights.sbomify.com/CVE-2011-3583/): Typo3 SQL injection due to faulty prepared statements (critical 9.8)
- [CVE-2011-4628](https://insights.sbomify.com/CVE-2011-4628/): Typo3 Authentication Bypass (critical 9.8)
- [CVE-2023-24814](https://insights.sbomify.com/CVE-2023-24814/): Persisted Cross-Site Scripting in Frontend Rendering in typo3 (high 8.8)
- [CVE-2021-41113](https://insights.sbomify.com/CVE-2021-41113/): Cross-Site-Request-Forgery in Backend URI Handling in Typo3 (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-6905 and fix it if it is affected.

What it is: CVE-2018-6905 is a medium-severity cross-site scripting vulnerability in Typo3 Typo3, published on 8 Apr 2018. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2018-6905 in the wild and no public exploit code.

Affected packages and fixed versions:
- typo3/cms (Packagist): affected all versions; fixed in 9.2.0
- typo3/cms (Packagist): affected all versions; fixed in 9.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-6905/ (Markdown: https://insights.sbomify.com/CVE-2018-6905/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-6905
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-6905
- OSV: https://osv.dev/vulnerability/CVE-2018-6905

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-6905/
Summaries are generated and may contain mistakes; the official description above is the record.
