# CVE-2018-7206: JupyterHub OAuthenticator elevation of privilege

> Attackers outside whitelisted GitLab groups can create unauthorized accounts on JupyterHub when group whitelisting is enabled.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Feb 2018
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-8x3m-m3x9-54fj, PYSEC-2018-68

## What is CVE-2018-7206?

CVE-2018-7206 is a high-severity authentication bypass vulnerability in n/a, published on 18 Feb 2018. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

An issue was discovered in Project Jupyter JupyterHub OAuthenticator 0.6.x before 0.6.2 and 0.7.x before 0.7.3. When using JupyterHub with GitLab group whitelisting for access control, group membership was not checked correctly, allowing members not in the whitelisted groups to create accounts on the Hub. (Users were not allowed to access other users' accounts, but could create their own accounts on the Hub linked to their GitLab account. GitLab authentication not using gitlab_group_whitelist is unaffected. No other Authenticators are affected.)

## Which versions are affected by CVE-2018-7206?

5 open source packages ship an affected version, including oauthenticator. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `oauthenticator` | PyPI | From 0.6 | 0.6.2, 0.7.3 |
| `oauthenticator` | PyPI | From 0.6 | 0.6.2 |
| `oauthenticator` | PyPI | From 0.6 | 0.6.2 |
| `oauthenticator` | PyPI | From 0.7 | 0.7.3 |
| `oauthenticator` | PyPI | From 0.7 | 0.7.3 |

Products: Jupyter Oauthenticator.

## How do I fix CVE-2018-7206?

Upgrade oauthenticator to a fixed version for your release line: 0.6.2 or 0.7.3.

## Is CVE-2018-7206 being exploited?

There is no known exploitation of CVE-2018-7206 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2026-33175](https://insights.sbomify.com/CVE-2026-33175/): OAuthenticator: Authentication Bypass in Auth0OAuthenticator via Unverified Email Claims (high 8.8)
- [CVE-2024-29033](https://insights.sbomify.com/CVE-2024-29033/): GoogleOAuthenticator.hosted_domain incorrectly verifies membership of an Google organization/workspace (high 7.5)
- [CVE-2020-26250](https://insights.sbomify.com/CVE-2020-26250/): Base class whitelist configuration ignored in OAuthenticator (medium 6.3)
- [CVE-2022-31027](https://insights.sbomify.com/CVE-2022-31027/): Authorization Bypass Through User-Controlled Key when using CILogonOAuthenticator in oauthenticator (medium 4.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-7206 and fix it if it is affected.

What it is: CVE-2018-7206 is a high-severity authentication bypass vulnerability in n/a, published on 18 Feb 2018. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-7206 in the wild and no public exploit code.

Affected packages and fixed versions:
- oauthenticator (PyPI): affected from 0.6; fixed in 0.6.2, 0.7.3
- oauthenticator (PyPI): affected from 0.6; fixed in 0.6.2
- oauthenticator (PyPI): affected from 0.6; fixed in 0.6.2
- oauthenticator (PyPI): affected from 0.7; fixed in 0.7.3
- oauthenticator (PyPI): affected from 0.7; fixed in 0.7.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-7206/ (Markdown: https://insights.sbomify.com/CVE-2018-7206/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-7206
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-7206
- OSV: https://osv.dev/vulnerability/CVE-2018-7206

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-7206/
Summaries are generated and may contain mistakes; the official description above is the record.
