# CVE-2018-7251: Anchor CMS Logs Credentials

> Attackers can access exposed error logs containing MySQL credentials, leading to potential database compromise.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Feb 2018
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-hxcw-pqqc-rv85

## What is CVE-2018-7251?

CVE-2018-7251 is a critical vulnerability in n/a, published on 19 Feb 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in config/error.php in Anchor 0.12.3. The error log is exposed at an errors.log URI, and contains MySQL credentials if a MySQL error (such as "Too many connections") has occurred.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2018-7251?

2 open source packages ship an affected version, including anchorcms/anchor-cms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `anchorcms/anchor-cms` | Packagist | All versions | 0.12.7 |
| `anchorcms/anchor-cms` | Packagist | All versions | 0.12.7 |

Products: Anchorcms Anchor.

## How do I fix CVE-2018-7251?

Upgrade anchorcms/anchor-cms to 0.12.7 or later.

## Is CVE-2018-7251 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2018-7251 exists.

Public exploit code:

- AnchorCMS < 0.12.3a - Information Disclosure (exploitdb)
- Anchor CMS 0.12.3 - Error Log Exposure (nuclei): http/cves/2018/CVE-2018-7251.yaml

## Other vulnerabilities in n/a

- [CVE-2020-12071](https://insights.sbomify.com/CVE-2020-12071/): Cross-site scripting in n/a (medium 4.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-7251 and fix it if it is affected.

What it is: CVE-2018-7251 is a critical vulnerability in n/a, published on 19 Feb 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2018-7251 exists.

Affected packages and fixed versions:
- anchorcms/anchor-cms (Packagist): affected all versions; fixed in 0.12.7
- anchorcms/anchor-cms (Packagist): affected all versions; fixed in 0.12.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-7251/ (Markdown: https://insights.sbomify.com/CVE-2018-7251/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-7251
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-7251
- OSV: https://osv.dev/vulnerability/CVE-2018-7251

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-7251/
Summaries are generated and may contain mistakes; the official description above is the record.
