CVE-2018-7408 Incorrect Permission Assignment for Critical Resource in NPM

High 7.8 Published Updated

Local attackers can escalate privileges by exploiting incorrect directory ownership changes in the npm package manager during installation.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Local or same network only
Victim action needed
Not needed
Fix
Available

What is CVE-2018-7408?

CVE-2018-7408 is a high-severity vulnerability in n/a, published on 22 Feb 2018. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

An issue was discovered in an npm 5.7.0 2018-02-21 pre-release (marked as "next: 5.7.0" and therefore automatically installed by an "npm upgrade -g npm" command, and also announced in the vendor's blog without mention of pre-release status). It might allow local users to bypass intended filesystem access restrictions because ownerships of /etc and /usr directories are being changed unexpectedly, related to a "correctMkdir" issue.

Weakness: CWE-732

Which versions are affected by CVE-2018-7408?

2 open source packages ship an affected version, including npm. It affects 1 product.

PackageAffectedFixed in
npm npmAll versions5.7.1
npm npmAll versions5.7.1

Products include Npmjs Npm.

How do I fix CVE-2018-7408?

Upgrade npm to 5.7.1 or later.

Is CVE-2018-7408 being exploited?

There is no known exploitation of CVE-2018-7408 in the wild and no public exploit code.

Sources

Also known as GHSA-ph34-pc88-72gc, MINI-62r5-j4c8-ghmg.

Is CVE-2018-7408 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free