{"answers":{"affected":"2 open source packages ship an affected version, including npm. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-7408 in the wild and no public exploit code.","fix":"Upgrade npm to 5.7.1 or later.","what":"CVE-2018-7408 is a high-severity vulnerability in n/a, published on 22 Feb 2018. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-7408 and fix it if it is affected.\n\nWhat it is: CVE-2018-7408 is a high-severity vulnerability in n/a, published on 22 Feb 2018. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-7408 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- npm (npm): affected all versions; fixed in 5.7.1\n- npm (npm): affected all versions; fixed in 5.7.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-7408/ (Markdown: https://insights.sbomify.com/CVE-2018-7408/index.md)","id":"CVE-2018-7408","markdown":"https://insights.sbomify.com/CVE-2018-7408/index.md","name":"CVE-2018-7408","record":{"aliases":["GHSA-ph34-pc88-72gc","MINI-62r5-j4c8-ghmg"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["privilege_escalation"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"npm package manager","requires_auth":"low_privilege","summary":"Local attackers can escalate privileges by exploiting incorrect directory ownership changes in the npm package manager during installation.","user_interaction":"not_required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"npm","vendor":"npmjs"}],"cvss":{"score":7.8,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-732","name":"Incorrect Permission Assignment for Critical Resource"}],"description":"An issue was discovered in an npm 5.7.0 2018-02-21 pre-release (marked as \"next: 5.7.0\" and therefore automatically installed by an \"npm upgrade -g npm\" command, and also announced in the vendor's blog without mention of pre-release status). It might allow local users to bypass intended filesystem access restrictions because ownerships of /etc and /usr directories are being changed unexpectedly, related to a \"correctMkdir\" issue.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Incorrect Permission Assignment for Critical Resource in NPM","id":"CVE-2018-7408","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"privilege_escalation","year":"2018"},"n_packages":2,"n_references":3,"next":{"headline":"Memory corruption in n/a","id":"CVE-2018-7409"},"packages":[{"ecosystem":"npm","fixed":["5.7.1"],"introduced":["0"],"last_affected":[],"package":"npm","purl":null,"source":"GHSA-ph34-pc88-72gc"},{"ecosystem":"npm","fixed":["5.7.1"],"introduced":["0"],"last_affected":[],"package":"npm","purl":"pkg:npm/npm","source":"GHSA-ph34-pc88-72gc"}],"prev":{"headline":"Memory corruption in n/a","id":"CVE-2018-7407"},"products":["n/a"],"published":"2018-02-22","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Local attackers can escalate privileges by exploiting incorrect directory ownership changes in the npm package manager during installation.","url":"https://insights.sbomify.com/CVE-2018-7408/"}