# CVE-2018-7408: Incorrect Permission Assignment for Critical Resource in NPM

> Local attackers can escalate privileges by exploiting incorrect directory ownership changes in the npm package manager during installation.

- **Severity:** High 7.8 (`CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Feb 2018
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-ph34-pc88-72gc, MINI-62r5-j4c8-ghmg

## What is CVE-2018-7408?

CVE-2018-7408 is a high-severity vulnerability in n/a, published on 22 Feb 2018. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

An issue was discovered in an npm 5.7.0 2018-02-21 pre-release (marked as "next: 5.7.0" and therefore automatically installed by an "npm upgrade -g npm" command, and also announced in the vendor's blog without mention of pre-release status). It might allow local users to bypass intended filesystem access restrictions because ownerships of /etc and /usr directories are being changed unexpectedly, related to a "correctMkdir" issue.

Weakness: CWE-732 (Incorrect Permission Assignment for Critical Resource)

## Which versions are affected by CVE-2018-7408?

2 open source packages ship an affected version, including npm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `npm` | npm | All versions | 5.7.1 |
| `npm` | npm | All versions | 5.7.1 |

Products: Npmjs Npm.

## How do I fix CVE-2018-7408?

Upgrade npm to 5.7.1 or later.

## Is CVE-2018-7408 being exploited?

There is no known exploitation of CVE-2018-7408 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-7408 and fix it if it is affected.

What it is: CVE-2018-7408 is a high-severity vulnerability in n/a, published on 22 Feb 2018. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-7408 in the wild and no public exploit code.

Affected packages and fixed versions:
- npm (npm): affected all versions; fixed in 5.7.1
- npm (npm): affected all versions; fixed in 5.7.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-7408/ (Markdown: https://insights.sbomify.com/CVE-2018-7408/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-7408
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-7408
- OSV: https://osv.dev/vulnerability/CVE-2018-7408

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-7408/
Summaries are generated and may contain mistakes; the official description above is the record.
